summaryrefslogtreecommitdiffstats
path: root/testing/mxml
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-22 14:42:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-23 12:29:16 +0000
commit79786eae2a3891d4f87bafb28e88301126c9042d (patch)
treef1c191bcfc25250ea0ae54e592cb22e7b955118a /testing/mxml
parent628d2a6a8f01c90875ee71de2e74b6a9e0b4ea73 (diff)
downloadaports-79786eae2a3891d4f87bafb28e88301126c9042d.tar.bz2
aports-79786eae2a3891d4f87bafb28e88301126c9042d.tar.xz
testing/mxml: new aport
small XML library that you can use to read and write XML files http://www.msweet.org/projects.php?Z3
Diffstat (limited to 'testing/mxml')
-rw-r--r--testing/mxml/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/mxml/APKBUILD b/testing/mxml/APKBUILD
new file mode 100644
index 000000000..f2884a0ad
--- /dev/null
+++ b/testing/mxml/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mxml
+pkgver=2.7
+pkgrel=0
+pkgdesc="small XML library that you can use to read and write XML files"
+url="http://www.msweet.org/projects.php?Z3"
+arch="all"
+license="LGPLv2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.msweet.org/files/project3/mxml-$pkgver.tar.gz"
+
+_builddir="$srcdir"/mxml-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make BUILDROOT="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="76f2ae49bf0f5745d5cb5d9507774dc9 mxml-2.7.tar.gz"
+sha256sums="a77200ee4c1e1cf2eb531595ec17ce31805760699d260915496c39d3388eb803 mxml-2.7.tar.gz"
+sha512sums="9fac34975c35d0ff9686a20a882824040b0b96b38ab9f1f5b1ef24a323668974860d4d977bb07c90a3e2b3410a2d8358eec1682b2c7ff2cda7f36f630ff97007 mxml-2.7.tar.gz"