summaryrefslogtreecommitdiffstats
path: root/testing/noip
diff options
context:
space:
mode:
authorcrow <crow@linux.org.ba>2014-04-29 17:07:01 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-30 08:58:15 +0000
commit90dd53cccec9757143e050fec568c68c3eac575a (patch)
tree583d35aa1d0fd4919a9f7b7138f4b2d00701b3e4 /testing/noip
parenta89ad077777fbb6465842e036a59b6c235423a23 (diff)
downloadaports-90dd53cccec9757143e050fec568c68c3eac575a.tar.bz2
aports-90dd53cccec9757143e050fec568c68c3eac575a.tar.xz
testing/noip: new aport
Diffstat (limited to 'testing/noip')
-rw-r--r--testing/noip/APKBUILD57
-rw-r--r--testing/noip/noip.confd3
-rw-r--r--testing/noip/noip.initd12
-rw-r--r--testing/noip/noip.post-install5
-rw-r--r--testing/noip/noip.pre-install0
5 files changed, 77 insertions, 0 deletions
diff --git a/testing/noip/APKBUILD b/testing/noip/APKBUILD
new file mode 100644
index 000000000..d8e9a1b0e
--- /dev/null
+++ b/testing/noip/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: vrabac <crow@linux.org.ba>
+# Maintainer:
+pkgname=noip
+pkgver=2.1.9
+pkgrel=0
+pkgdesc="Dynamic DNS Client Updater for no-ip.com services"
+url="http://www.no-ip.com/downloads.php?page=linux"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages=""
+source="http://www.no-ip.com/client/linux/noip-duc-linux.tar.gz
+ noip.initd
+ noip.confd
+ "
+
+_builddir="$srcdir"/noip-$pkgver-1
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i '/^#define CONFIG_FILEPATH/s/PREFIX//' noip2.c || return 1
+ sed -i '/^#define CONFIG_FILENAME/s/PREFIX//' noip2.c || return 1
+}
+
+build() {
+ cd "$_builddir"
+ cc -Wall $CLFAGS $LDFLAGS -g -Dlinux -DPREFIX=/usr noip2.c -o noip2 -Wno-unused-but-set-variable
+}
+
+package() {
+ cd "$_builddir"
+
+ install -Dm755 "$_builddir"/noip2 \
+ "$pkgdir"/usr/bin/noip2 || return 1
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname || return 1
+}
+
+md5sums="3b0f5f2ff8637c73ab337be403252a60 noip-duc-linux.tar.gz
+55a411022561a31ca719f8b80783534d noip.initd
+811e1a4255b13db92e3218d7717c21ac noip.confd"
+sha256sums="82b9bafab96a0c53b21aaef688bf70b3572e26217b5e2072bdb09da3c4a6f593 noip-duc-linux.tar.gz
+876e6f06feb4ab6447ad2d85d4b615665d03cae2f6d5572a47036fe57f46a621 noip.initd
+c51f88cca625eb05de518822b6e2dd8fb07773d90a16aad41dc4161a63e9d52c noip.confd"
+sha512sums="6c32397f31e6f4875a2429398c2627cbe52abba569830ddc1190fed3f4c6cb23e232e60b23d9fa97940f98a1c5c019a89812844f92a655c6ebf275b784015125 noip-duc-linux.tar.gz
+e16b4821caeb99118c100aff179aa9450e6d09dbf6f8520952cabd129c43ddf55b564f33e3eb72d8d455d44f2ebb289b79f122e0b41a2ace2f892f7e7d08b9dd noip.initd
+5c99e2c64d4f065d68a8ba98a0f1c1a857f4d038c2050d37a253b28c4f2a75b96e4ff9721bd51777f0b4997d6683b9a5afa8c8c59ffb32119eb0bb5968b0f669 noip.confd"
diff --git a/testing/noip/noip.confd b/testing/noip/noip.confd
new file mode 100644
index 000000000..7a8889aba
--- /dev/null
+++ b/testing/noip/noip.confd
@@ -0,0 +1,3 @@
+noip_conf="/etc/no-ip2.conf"
+noip_pid="/var/run/noip.pid"
+noip_args="-c $noip_conf --pidfile $noip_pid"
diff --git a/testing/noip/noip.initd b/testing/noip/noip.initd
new file mode 100644
index 000000000..ff897cfb9
--- /dev/null
+++ b/testing/noip/noip.initd
@@ -0,0 +1,12 @@
+#!/sbin/runscript
+
+name=noip
+command=/usr/sbin/noip2
+command_args=$noip_args
+pidfile=$noip_pid
+
+depend() {
+ use logger dns
+ need net
+ after firewall
+}
diff --git a/testing/noip/noip.post-install b/testing/noip/noip.post-install
new file mode 100644
index 000000000..8e1bc88b3
--- /dev/null
+++ b/testing/noip/noip.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+ echo
+ echo 'Before running noip2 you must configure it.'
+ echo 'To configure noip2 run the command "noip2 -C -Y"'
+ echo
diff --git a/testing/noip/noip.pre-install b/testing/noip/noip.pre-install
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/testing/noip/noip.pre-install