summaryrefslogtreecommitdiffstats
path: root/testing/nss-pam-ldapd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-05-30 10:03:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-05-30 10:04:14 +0000
commit73629368469eb638b75141001ba442b1478ce364 (patch)
tree8a85d008b7ea8a714b757df5a0680d99bf87376b /testing/nss-pam-ldapd
parenteb16b759271baa15a9b9ea3f0c5b4b8f2b16a77b (diff)
downloadaports-73629368469eb638b75141001ba442b1478ce364.tar.bz2
aports-73629368469eb638b75141001ba442b1478ce364.tar.xz
testing/nss-pam-ldapd: new aport
An nsswitch module which uses directory servers http://arthurdejong.org/nss-pam-ldapd/ ref #2911
Diffstat (limited to 'testing/nss-pam-ldapd')
-rw-r--r--testing/nss-pam-ldapd/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/nss-pam-ldapd/APKBUILD b/testing/nss-pam-ldapd/APKBUILD
new file mode 100644
index 000000000..55b68f059
--- /dev/null
+++ b/testing/nss-pam-ldapd/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=nss-pam-ldapd
+pkgver=0.9.3
+pkgrel=0
+pkgdesc="An nsswitch module which uses directory servers"
+url="http://arthurdejong.org/nss-pam-ldapd/"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev="linux-pam-dev openldap-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://arthurdejong.org/nss-pam-ldapd/nss-pam-ldapd-$pkgver.tar.gz"
+
+_builddir="$srcdir"/nss-pam-ldapd-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-nss \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="89c433fa238c8d7b9420260768bbd03c nss-pam-ldapd-0.9.3.tar.gz"
+sha256sums="b42ad9fef4664b21845358c32e9c776c31858df2981b9e0e7bf686ce511884fa nss-pam-ldapd-0.9.3.tar.gz"
+sha512sums="8f2e68d5adf63d60f6f60fd2abbbde17a8cd9c7f082d7302ab1201168c624eeffe4d63c459172723cc20f120b3d2b091fe838c9d8857bc01aa8fcb3b3dd99825 nss-pam-ldapd-0.9.3.tar.gz"