summaryrefslogtreecommitdiffstats
path: root/testing/omxplayer/fix-makefile.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-09-25 10:56:23 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-09-25 10:56:55 +0000
commit84f93a1605061cf9685987591972dfe211311051 (patch)
tree7fe5ee01309bc82d73de6c564fc5fd7f646e6285 /testing/omxplayer/fix-makefile.patch
parentd8c7627e8ec97100957ce79c584acc259dea2e3f (diff)
downloadaports-84f93a1605061cf9685987591972dfe211311051.tar.bz2
aports-84f93a1605061cf9685987591972dfe211311051.tar.xz
testing/omxplayer: upgrade to git snapshot 2014-09-22
Diffstat (limited to 'testing/omxplayer/fix-makefile.patch')
-rw-r--r--testing/omxplayer/fix-makefile.patch24
1 files changed, 13 insertions, 11 deletions
diff --git a/testing/omxplayer/fix-makefile.patch b/testing/omxplayer/fix-makefile.patch
index cc9f46678..96d57a262 100644
--- a/testing/omxplayer/fix-makefile.patch
+++ b/testing/omxplayer/fix-makefile.patch
@@ -1,7 +1,7 @@
---- omxplayer-7af21f596378e5efeceebedff9c4a298e2d06d98.orig/Makefile
-+++ omxplayer-7af21f596378e5efeceebedff9c4a298e2d06d98/Makefile
-@@ -46,7 +48,7 @@
- $(CXX) $(CFLAGS) $(INCLUDES) -c $< -o $@ -Wno-deprecated-declarations
+--- omxplayer-6ee9a0a5488119786990b6f91990d59d6e35427c/Makefile.orig
++++ omxplayer-6ee9a0a5488119786990b6f91990d59d6e35427c/Makefile
+@@ -48,7 +48,7 @@
+ omxplayer.o: help.h keys.h
version:
- bash gen_version.sh > version.h
@@ -9,18 +9,20 @@
omxplayer.bin: version $(OBJS)
$(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
-@@ -64,12 +66,9 @@
+@@ -79,14 +79,12 @@
make -f Makefile.ffmpeg
make -f Makefile.ffmpeg install
--dist: omxplayer.bin
-- mkdir -p $(DIST)/usr/lib/omxplayer
-+install: omxplayer.bin
+-dist: omxplayer.bin omxplayer.1
++install: omxplayer.bin omxplayer.1
+ mkdir -p $(DIST)/usr/lib/omxplayer
mkdir -p $(DIST)/usr/bin
- mkdir -p $(DIST)/usr/share/doc
+ mkdir -p $(DIST)/usr/share/doc/omxplayer
+ mkdir -p $(DIST)/usr/share/man/man1
- cp omxplayer omxplayer.bin $(DIST)/usr/bin
+ cp omxplayer.bin $(DIST)/usr/bin/omxplayer
- cp COPYING $(DIST)/usr/share/doc/
- cp README.md $(DIST)/usr/share/doc/README
+ cp COPYING $(DIST)/usr/share/doc/omxplayer
+ cp README.md $(DIST)/usr/share/doc/omxplayer/README
+ cp omxplayer.1 $(DIST)/usr/share/man/man1
- cp -a ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
- cd $(DIST); tar -czf ../$(DIST).tgz *