summaryrefslogtreecommitdiffstats
path: root/testing/omxplayer/fix-makefile.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-02-28 12:47:42 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-02-28 12:47:58 +0000
commit8ac336d8c9b889ad571754b39b3f9da5e07a826b (patch)
treef7b11f5207d8812e07d6b90bfc6bd4d18aecac59 /testing/omxplayer/fix-makefile.patch
parent8a4fab725b3abc6785db872e5cc58ca9c2f7e20a (diff)
downloadaports-8ac336d8c9b889ad571754b39b3f9da5e07a826b.tar.bz2
aports-8ac336d8c9b889ad571754b39b3f9da5e07a826b.tar.xz
testing/omxplayer: upgrade to snapshot of 2014-02-20
Diffstat (limited to 'testing/omxplayer/fix-makefile.patch')
-rw-r--r--testing/omxplayer/fix-makefile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/omxplayer/fix-makefile.patch b/testing/omxplayer/fix-makefile.patch
new file mode 100644
index 000000000..1dd8f6dfb
--- /dev/null
+++ b/testing/omxplayer/fix-makefile.patch
@@ -0,0 +1,25 @@
+--- omxplayer-7af21f596378e5efeceebedff9c4a298e2d06d98.orig/Makefile
++++ omxplayer-7af21f596378e5efeceebedff9c4a298e2d06d98/Makefile
+@@ -46,7 +48,7 @@
+ $(CXX) $(CFLAGS) $(INCLUDES) -c $< -o $@ -Wno-deprecated-declarations
+
+ version:
+- bash gen_version.sh > version.h
++ sh gen_version.sh > version.h
+
+ omxplayer.bin: version $(OBJS)
+ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+@@ -64,12 +66,9 @@
+ make -f Makefile.ffmpeg
+ make -f Makefile.ffmpeg install
+
+-dist: omxplayer.bin
+- mkdir -p $(DIST)/usr/lib/omxplayer
++install: omxplayer.bin
+ mkdir -p $(DIST)/usr/bin
+ mkdir -p $(DIST)/usr/share/doc
+ cp omxplayer omxplayer.bin $(DIST)/usr/bin
+ cp COPYING $(DIST)/usr/share/doc/
+ cp README.md $(DIST)/usr/share/doc/README
+- cp -a ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
+- cd $(DIST); tar -czf ../$(DIST).tgz *