summaryrefslogtreecommitdiffstats
path: root/testing/pdns-gui/APKBUILD
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-04-08 05:37:54 -0500
committerMatt Smith <mcs@darkregion.net>2011-04-08 05:38:13 -0500
commitf716325f16fbabcc7586d67bc1aa4506a23754c7 (patch)
tree444b1981532a8e72669efba1017842c4beb3ede3 /testing/pdns-gui/APKBUILD
parent06d067525070d325db98a4a95fedad6eb40f7060 (diff)
downloadaports-f716325f16fbabcc7586d67bc1aa4506a23754c7.tar.bz2
aports-f716325f16fbabcc7586d67bc1aa4506a23754c7.tar.xz
testing/pdns-gui: should work now
Diffstat (limited to 'testing/pdns-gui/APKBUILD')
-rw-r--r--testing/pdns-gui/APKBUILD32
1 files changed, 27 insertions, 5 deletions
diff --git a/testing/pdns-gui/APKBUILD b/testing/pdns-gui/APKBUILD
index f7a82dc00..481279012 100644
--- a/testing/pdns-gui/APKBUILD
+++ b/testing/pdns-gui/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=pdns-gui
pkgver=0.3.3
-pkgrel=0
+pkgrel=1
pkgdesc="Web-based GUI for administering PowerDNS"
url="http://code.google.com/p/pdns-gui/"
arch="noarch"
@@ -14,6 +14,10 @@ install="$pkgname.post-install $pkgname.post-upgrade"
subpackages=
source="http://$pkgname.googlecode.com/files/$pkgname.$pkgver.tgz
0010-replace-bash-with-sh.patch
+ 0020-update-for-mysql55.patch
+ 0030-remove-zend.ze1_compatibility_mode-option.patch
+ 0040-alpine-default-htaccess-fix.patch
+ $pkgname.apache2.conf
"
_builddir="$srcdir"/$pkgname.$pkgver
@@ -32,10 +36,28 @@ build() {
}
package() {
- mkdir -p "$pkgdir"/var/www/$pkgname || return 1
- cp -a "$_builddir"/* "$pkgdir"/var/www/$pkgname/ || return 1
- rm "$pkgdir"/var/www/$pkgname/INSTALL || return 1
+ # copy pdns-gui
+ mkdir -p "$pkgdir"/usr/share/webapps/$pkgname || return 1
+ cp -a "$_builddir"/* "$pkgdir"/usr/share/webapps/$pkgname/ || return 1
+
+ # move log directory
+ mkdir -p "$pkgdir"/var/log/$pkgname || return 1
+ chmod 2755 "$pkgdir"/var/log/$pkgname || return 1
+ rm -rf "$pkgdir"/usr/share/webapps/$pkgname/log || return 1
+ ln -fs /var/log/$pkgname "$pkgdir"/usr/share/webapps/$pkgname/log \
+ || return 1
+
+ # remove the install file
+ rm "$pkgdir"/usr/share/webapps/$pkgname/INSTALL || return 1
+
+ # install the apache2 config
+ install -Dm644 "$srcdir"/$pkgname.apache2.conf \
+ "$pkgdir"/etc/apache2/conf.d/$pkgname.conf || return 1
}
md5sums="caa45c5408764ccd98cfffd69e5e976f pdns-gui.0.3.3.tgz
-98acdea457a4805c77cea373a6d57029 0010-replace-bash-with-sh.patch"
+98acdea457a4805c77cea373a6d57029 0010-replace-bash-with-sh.patch
+21683d18b30aef6082803339413f8c42 0020-update-for-mysql55.patch
+8865c965b6c81dbf2d9de5f8956b0ae0 0030-remove-zend.ze1_compatibility_mode-option.patch
+d621eecb4f688640cb514aff1ea8ef7d 0040-alpine-default-htaccess-fix.patch
+2a4d9133e4ac0c22ed7bd408052b5de0 pdns-gui.apache2.conf"