summaryrefslogtreecommitdiffstats
path: root/testing/perl-apache2-sitecontrol
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-01-02 08:28:52 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-01-02 08:28:52 +0000
commit330a49e1c7a5b4cf3014a546d92594280f0626c2 (patch)
tree1c1b3282e5cd8e2be55ab8c7dc0b3d3db805108d /testing/perl-apache2-sitecontrol
parenteb275884ad7ab102a4014d6d45d1a7eac646bbba (diff)
downloadaports-330a49e1c7a5b4cf3014a546d92594280f0626c2.tar.bz2
aports-330a49e1c7a5b4cf3014a546d92594280f0626c2.tar.xz
testing/perl-algorithm-diff: new apkbuild
Diffstat (limited to 'testing/perl-apache2-sitecontrol')
-rw-r--r--testing/perl-apache2-sitecontrol/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/perl-apache2-sitecontrol/APKBUILD b/testing/perl-apache2-sitecontrol/APKBUILD
new file mode 100644
index 000000000..67768ea1b
--- /dev/null
+++ b/testing/perl-apache2-sitecontrol/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-apache2-sitecontrol
+_pkgreal=Apache2-SiteControl
+pkgver=1.05
+pkgrel=0
+pkgdesc="Perl module for Apache2-SiteControl"
+url="http://search.cpan.org/dist/Apache2-SiteControl/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="apache2"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AW/AWKAY/Apache2/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="28beba3deeb24b3a4980f6491eb655f7 Apache2-SiteControl-1.05.tar.gz"