summaryrefslogtreecommitdiffstats
path: root/testing/perl-carp-clan
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-08 21:17:58 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commit813fe7c95f33c59b071ac105e8f5665b70694ba0 (patch)
tree3df0e92d00b943314123b2aabde2f9e9ff65dcad /testing/perl-carp-clan
parentb101561418b3859e4326770b24be8fa233b39035 (diff)
downloadaports-813fe7c95f33c59b071ac105e8f5665b70694ba0.tar.bz2
aports-813fe7c95f33c59b071ac105e8f5665b70694ba0.tar.xz
Initial APKBUILD for perl-carp-clan
Diffstat (limited to 'testing/perl-carp-clan')
-rw-r--r--testing/perl-carp-clan/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/perl-carp-clan/APKBUILD b/testing/perl-carp-clan/APKBUILD
new file mode 100644
index 000000000..a3407ee3e
--- /dev/null
+++ b/testing/perl-carp-clan/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=perl-carp-clan
+_realname=Carp-Clan
+pkgver=6.04
+pkgrel=0
+pkgdesc="Report errors from perspective of caller of a clan of modules "
+url="http://search.cpan.org/~stbey/Carp-Clan-6.04/"
+arch="noarch"
+license="PerlArtistic"
+depends="perl perl-test-exception"
+depends_dev=""
+makedepends="perl-dev perl-test-exception"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/S/ST/STBEY/$_realname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="b6316bc51bb530d994f2784615939fb2 Carp-Clan-6.04.tar.gz"