summaryrefslogtreecommitdiffstats
path: root/testing/py-businesstime
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-09-12 09:31:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-29 06:48:10 +0000
commit172bd6b45a33b2f4d94fe55c80bcad664a85d22d (patch)
treeb204a8af1393df698186467901e3f96698273fb2 /testing/py-businesstime
parentd8a5bbe946dedc91fe5ca1a411e2da7a4c90ae57 (diff)
downloadaports-172bd6b45a33b2f4d94fe55c80bcad664a85d22d.tar.bz2
aports-172bd6b45a33b2f4d94fe55c80bcad664a85d22d.tar.xz
testing/py-businesstime: new aport
A python utility for calculating business time between two datetimes https://github.com/seatgeek/businesstime
Diffstat (limited to 'testing/py-businesstime')
-rw-r--r--testing/py-businesstime/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-businesstime/APKBUILD b/testing/py-businesstime/APKBUILD
new file mode 100644
index 000000000..da1b2adbc
--- /dev/null
+++ b/testing/py-businesstime/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-businesstime
+_pkgname=businesstime
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="A Python utility for calculating business time between two datetimes"
+url="https://github.com/seatgeek/businesstime"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="6bba38b1f60d4a4d6c49ef9a0ef6a3ec businesstime-0.1.4.tar.gz"
+sha256sums="65514b0833c1234f82f7386956fe1b558fa70bdc5c05605dbdb740695d99c2a6 businesstime-0.1.4.tar.gz"
+sha512sums="7ef7b6053855708c8aac48a8f6af34f55e2a389a6a7b954c3c6e2f542ced5ef22c73392c483b2fe8de387c0c8b57eea6edb0ce714ba66755b10d5ea3eb1add34 businesstime-0.1.4.tar.gz"