summaryrefslogtreecommitdiffstats
path: root/testing/py-httplib2
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-15 19:08:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:34 +0000
commit46cd4fef21410ec2b200f13c20f81ab416012814 (patch)
tree5df7847fce209d7273ba52abfb01cf08547b7451 /testing/py-httplib2
parent323941ca0717fe4f2b0381cc5f9ef030715c9836 (diff)
downloadaports-46cd4fef21410ec2b200f13c20f81ab416012814.tar.bz2
aports-46cd4fef21410ec2b200f13c20f81ab416012814.tar.xz
testing/py-httplib2: new aport
A Python HTTP client library http://code.google.com/p/httplib2/
Diffstat (limited to 'testing/py-httplib2')
-rw-r--r--testing/py-httplib2/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-httplib2/APKBUILD b/testing/py-httplib2/APKBUILD
new file mode 100644
index 000000000..df5418270
--- /dev/null
+++ b/testing/py-httplib2/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-httplib2
+_pkgname=httplib2
+pkgver=0.8
+pkgrel=0
+pkgdesc="A Python HTTP client library"
+url="http://code.google.com/p/httplib2/"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="94cb8a3b196dfd19253c46609489d9f1 httplib2-0.8.tar.gz"
+sha256sums="cee59fdaa97a40ac505bb0629bdc8ba9ba79012d099ef11d6d3a284b7e369c9c httplib2-0.8.tar.gz"
+sha512sums="f3febcb5222359d13b9963ec2d4f01cac406617c6217ec6640e0484b66c8b1fd26a0fb02a7db9b4e62ae67f73110e9c99bae6a5ae6288abdce7aa14ffeffd229 httplib2-0.8.tar.gz"