summaryrefslogtreecommitdiffstats
path: root/testing/py-pyacoustid
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-11 13:00:19 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-11 13:00:19 +0200
commit12820b2c6dd828455b6def5ec19a12fedd9502dd (patch)
tree70d47fc52caf3a35f2ea1b6e324a00918f036b5f /testing/py-pyacoustid
parent24b923886da1187d502a79ffe1f0549a730ab6f8 (diff)
downloadaports-12820b2c6dd828455b6def5ec19a12fedd9502dd.tar.bz2
aports-12820b2c6dd828455b6def5ec19a12fedd9502dd.tar.xz
testing/py-pyacoustid: new aport
Diffstat (limited to 'testing/py-pyacoustid')
-rw-r--r--testing/py-pyacoustid/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-pyacoustid/APKBUILD b/testing/py-pyacoustid/APKBUILD
new file mode 100644
index 000000000..8695ec6d6
--- /dev/null
+++ b/testing/py-pyacoustid/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-pyacoustid
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Bindings for Chromaprint acoustic fingerprinting and the Acoustid API"
+url="https://github.com/sampsyo/pyacoustid"
+arch="noarch"
+license="MIT"
+depends="python chromaprint"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/p/pyacoustid/pyacoustid-$pkgver.tar.gz"
+
+_builddir="$srcdir"/pyacoustid-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 || return 1
+}
+
+md5sums="b27c714d530300b917eb869726334226 pyacoustid-1.1.0.tar.gz"
+sha256sums="0117039cb116af245e6866e8e8bf3c9c8b2853ad087142bd0c2dfc0acc09d452 pyacoustid-1.1.0.tar.gz"
+sha512sums="16b1c6cc1c27c02847b43c953e0fa9d525652b0583e321aaceb2f0c4bbea2e2f6956a6f0a95b1cd61124dc17e0751819ab223513ec22f27cf83246199ea8999d pyacoustid-1.1.0.tar.gz"