summaryrefslogtreecommitdiffstats
path: root/testing/py-sphinx-theme-guzzle
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-17 19:26:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:53 +0000
commit0225176418925d759e40c46d397428315d0ed9a9 (patch)
tree30dd271def52e65ab0a95d302fbea7841d30fee9 /testing/py-sphinx-theme-guzzle
parent02084e4a286313d5044fd239084a72f68d015874 (diff)
downloadaports-0225176418925d759e40c46d397428315d0ed9a9.tar.bz2
aports-0225176418925d759e40c46d397428315d0ed9a9.tar.xz
testing/py-sphinx-theme-guzzle: new aport
The Guzzle Sphinx theme https://github.com/guzzle/guzzle_sphinx_theme
Diffstat (limited to 'testing/py-sphinx-theme-guzzle')
-rw-r--r--testing/py-sphinx-theme-guzzle/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinx-theme-guzzle/APKBUILD b/testing/py-sphinx-theme-guzzle/APKBUILD
new file mode 100644
index 000000000..35a120d89
--- /dev/null
+++ b/testing/py-sphinx-theme-guzzle/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinx-theme-guzzle
+_pkgname=guzzle_sphinx_theme
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="The Guzzle Sphinx theme"
+url="https://github.com/guzzle/guzzle_sphinx_theme"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="d66821491087ad33b2a030f5f155bf31 guzzle_sphinx_theme-0.2.1.tar.gz"
+sha256sums="73799d1789c07ff89a84f2c13dafce06e8d9c91ae5de9b5ce907b5f5b59fcad8 guzzle_sphinx_theme-0.2.1.tar.gz"
+sha512sums="2775b47a2ee27ab42de8247322676ab1bf2c4beb67e4c574b05ba08c22a71b61d5766d4dfa955f1f0dccfd57526b8251d8cec875bbf53d86e98402ddf3d20a81 guzzle_sphinx_theme-0.2.1.tar.gz"