summaryrefslogtreecommitdiffstats
path: root/testing/py-tkinter
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-09 06:45:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-09 06:45:44 +0000
commitaeddbf1ff35abea4633a871fa68dd1b572904773 (patch)
treea9dd952241a6fd319d1c4051d05a128a5e30082b /testing/py-tkinter
parentbd1de6ce91a3e6a0c2e29aa98622f99607d56333 (diff)
downloadaports-aeddbf1ff35abea4633a871fa68dd1b572904773.tar.bz2
aports-aeddbf1ff35abea4633a871fa68dd1b572904773.tar.xz
testing/py-tkinter: build only shared modules and check python version
we dont need to build everything
Diffstat (limited to 'testing/py-tkinter')
-rw-r--r--testing/py-tkinter/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/testing/py-tkinter/APKBUILD b/testing/py-tkinter/APKBUILD
index 6c7c114ef..be81d81aa 100644
--- a/testing/py-tkinter/APKBUILD
+++ b/testing/py-tkinter/APKBUILD
@@ -13,7 +13,7 @@ license="custom"
subpackages=""
depends=""
makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev
- libffi-dev paxctl tk-dev"
+ libffi-dev paxctl tk-dev python-dev"
source="http://www.$pkgname.org/ftp/$_pkgname/$pkgver/Python-$pkgver.tar.xz
find_library.patch
unchecked-ioctl.patch
@@ -27,6 +27,13 @@ prepare() {
esac
done
+ # verify that python version corresponds with system python version
+ _pyver=$(python -c 'import platform; print platform.python_version()')
+ if [ "$_pyver" != "$pkgver" ]; then
+ error "$pkgver does not correspond with python $_pyver"
+ return 1
+ fi
+
# Make sure we use system libs
rm -r Modules/expat Modules/_ctypes/libffi* Modules/zlib || return 1
@@ -55,12 +62,12 @@ build() {
--with-tcltk-libs="`pkg-config --libs tk`" \
--with-tcltk-includes="`pkg-config --cflags tk`" \
|| return 1
- make || return 1
+ make sharedmods || return 1
}
package() {
cd "$srcdir/Python-$pkgver"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" sharedinstall || return 1
find "$pkgdir/" -type f ! -name _tkinter.so -exec rm -f '{}' + \
|| return 1
find "$pkgdir/" -type l -exec rm -f '{}' + || return 1