summaryrefslogtreecommitdiffstats
path: root/testing/py-yurl
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-03-03 20:01:18 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-03-04 09:50:18 +0000
commitde7f4b0b9676cb37db31c61575484f5daf6dabc2 (patch)
tree1d921f79e1ccfad3ebcb8e5267f5b02eec33863d /testing/py-yurl
parent4ad76b98b0f438a4225ec03d4f31fdc08d703817 (diff)
downloadaports-de7f4b0b9676cb37db31c61575484f5daf6dabc2.tar.bz2
aports-de7f4b0b9676cb37db31c61575484f5daf6dabc2.tar.xz
testing/py-yurl: new aport
Yurl is a replacement of built in python urlparse module. Key features of yurl are: - pythonic api - better compliance with RFC 3986 - nice performance - support for python 2.6, 2.7, 3.2, 3.3 and pypy 1.9 with single codebase Website: https://github.com/homm/yurl/
Diffstat (limited to 'testing/py-yurl')
-rw-r--r--testing/py-yurl/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-yurl/APKBUILD b/testing/py-yurl/APKBUILD
new file mode 100644
index 000000000..9055e5c93
--- /dev/null
+++ b/testing/py-yurl/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-yurl
+_pkgname=YURL
+pkgver=0.10
+pkgrel=0
+pkgdesc="An alternative Python url manipulation library"
+url="https://github.com/homm/yurl/"
+arch="noarch"
+license="unknown"
+depends=""
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="ece0bba0c9b0902964f80c236760a2f3 YURL-0.10.tar.gz"
+sha256sums="10b8fd15b7b582fade998b350c67686ca827f68938406fbb0025fd3a10dddbdb YURL-0.10.tar.gz"
+sha512sums="c37d172a96fbb5e69ec1566f2e93f3a2cbd66ad31229d7bac1010460e2dddb726b579c4c56f6345975977f4cbf6188408bdf9b48616047ddcab9e95823e1ffc4 YURL-0.10.tar.gz"