summaryrefslogtreecommitdiffstats
path: root/testing/pyflakes
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-05 20:41:42 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 14:35:46 +0200
commitb287f18488a2554062b7ecd187218f5cee5e44b6 (patch)
tree77d3f1f2dad13c28e66937d89735c4cdb1b0a93c /testing/pyflakes
parentd4e193c8ab96231b13ae33735f82a27c4830c3ac (diff)
downloadaports-b287f18488a2554062b7ecd187218f5cee5e44b6.tar.bz2
aports-b287f18488a2554062b7ecd187218f5cee5e44b6.tar.xz
testing/pyflakes: new aport
A modular source code checker https://bitbucket.org/tarek/flake8/wiki/Home
Diffstat (limited to 'testing/pyflakes')
-rw-r--r--testing/pyflakes/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/pyflakes/APKBUILD b/testing/pyflakes/APKBUILD
new file mode 100644
index 000000000..dfa8e750e
--- /dev/null
+++ b/testing/pyflakes/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=pyflakes
+pkgver=0.7.3
+pkgrel=0
+pkgdesc="A passive checker of Python programs"
+url="https://launchpad.net/pyflakes"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="ec94ac11cb110e6e72cca23c104b66b1 pyflakes-0.7.3.tar.gz"
+sha256sums="dbd2c940a1030a4f811afc1a04017a44011c0cb54f8f384b66aa624097d9b5e3 pyflakes-0.7.3.tar.gz"
+sha512sums="a77fc6a1ca1bdb8aaf31e3653389c7c9357433b8b64dbd3104068a4ce900a019d3dbba5bd23c313fc70398f6f2767a3639cf7b915d3edbc1e1d1e1a03932729d pyflakes-0.7.3.tar.gz"