summaryrefslogtreecommitdiffstats
path: root/testing/pytest
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-08-21 20:55:05 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-08-23 10:29:06 +0000
commitc1aa2842a0bf660ede09c9be378b2a200354e18c (patch)
tree82a9df71b828046af7ac2de43a94f1ec84df1c44 /testing/pytest
parent9d500de059147026b1489a859e3e11396a8a8281 (diff)
downloadaports-c1aa2842a0bf660ede09c9be378b2a200354e18c.tar.bz2
aports-c1aa2842a0bf660ede09c9be378b2a200354e18c.tar.xz
testing/pytest: new aport
A python test library http://pytest.org
Diffstat (limited to 'testing/pytest')
-rw-r--r--testing/pytest/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/pytest/APKBUILD b/testing/pytest/APKBUILD
new file mode 100644
index 000000000..2e4e2a3a8
--- /dev/null
+++ b/testing/pytest/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=pytest
+_pkgname=pytest
+pkgver=2.6.1
+pkgrel=0
+pkgdesc="A python test library"
+url="http://pytest.org"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="bb353f6cf6d9ff83ff7f2dfbeaca47a3 pytest-2.6.1.tar.gz"
+sha256sums="994dabcb3149659d259add2aa7d11bff4d35efb7cf4c8233fa9b0b62c1255c3c pytest-2.6.1.tar.gz"
+sha512sums="1bfbe27491800943484616a37cfe0f2f8677e3b2a25aee19f842bdf66a9c0205af8c2aecaeb50823970ab9f7042b1bb9115e3c4d689fe568a17a062c50ead829 pytest-2.6.1.tar.gz"