summaryrefslogtreecommitdiffstats
path: root/testing/raspberrypi
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-09-24 08:08:33 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-09-24 08:11:32 +0000
commitc2bd759ec687b7975232cfcb3d7916c540f9ed7f (patch)
treeae139d7cf057602dcfb7f3190f215bca082f4f40 /testing/raspberrypi
parent647fe352d560e1ec51a75a1aee950759243e0fdb (diff)
downloadaports-c2bd759ec687b7975232cfcb3d7916c540f9ed7f.tar.bz2
aports-c2bd759ec687b7975232cfcb3d7916c540f9ed7f.tar.xz
testing/raspberrypi: upgrade to git snapshot 2014-09-19
Diffstat (limited to 'testing/raspberrypi')
-rw-r--r--testing/raspberrypi/APKBUILD20
-rw-r--r--testing/raspberrypi/fix-stdc99.patch24
2 files changed, 36 insertions, 8 deletions
diff --git a/testing/raspberrypi/APKBUILD b/testing/raspberrypi/APKBUILD
index 838096a72..2e295e6e9 100644
--- a/testing/raspberrypi/APKBUILD
+++ b/testing/raspberrypi/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=raspberrypi
-pkgver=0.20140524
-_commitid=4855a45b118cb7b97b83e5160551db9813487c91
+pkgver=0.20140919
+_commitid=ffcc4bd7c4875b71376c4240116e251652c9bec0
pkgrel=0
pkgdesc="Raspberry Pi support tools"
url="https://github.com/raspberrypi/userland"
@@ -14,6 +14,7 @@ options="!fhs"
subpackages="$pkgname-dev $pkgname-libs"
source="raspberrypi-$pkgver.tar.gz::https://github.com/raspberrypi/userland/archive/$_commitid.tar.gz
fix-musl.patch
+ fix-stdc99.patch
"
_sourcedir="$srcdir"/userland-$_commitid
@@ -52,9 +53,12 @@ libs() {
mv "$pkgdir"/opt/vc/lib/* "$subpkgdir"/opt/vc/lib
}
-md5sums="86e35b07caac9d7dd3a8623a3ee59318 raspberrypi-0.20140524.tar.gz
-49a33897d575a07514b1b8d288361f63 fix-musl.patch"
-sha256sums="07a43686dc972d903d3af7bfb1262591bce09f2c3a772286fa3898e3a5fab216 raspberrypi-0.20140524.tar.gz
-e8cbc558094d745f99a14f354720be0fdf81f2ebc48651fed32c4ae1ef1fd649 fix-musl.patch"
-sha512sums="b2631a5b85d9c6a857f6d4266c30145314579fe81535100d7a2775477eb2663c1799efb0d52555660fab11fa8ccb4af0219c85d04e9c3e9b71f663167354273f raspberrypi-0.20140524.tar.gz
-8092d59985d7380b533896c6f8aad6f4838e8cf414a8052c43fa4330bc07ce6be7d2d0cc3bc280f3f63b537687cb8f51c93ef608db82fe6638505d03b317581f fix-musl.patch"
+md5sums="6627660ea21c35859ada7d638247e049 raspberrypi-0.20140919.tar.gz
+49a33897d575a07514b1b8d288361f63 fix-musl.patch
+7da1da67742eac08b7a36b70cea6a50d fix-stdc99.patch"
+sha256sums="a9172bb498a1537dba74df5bcef67a1b83244e45282130b05fd2873c49e15ac0 raspberrypi-0.20140919.tar.gz
+e8cbc558094d745f99a14f354720be0fdf81f2ebc48651fed32c4ae1ef1fd649 fix-musl.patch
+6cd7d652073790b66760eea41042124eb5426b23a515ad6108dc4cb25b9f61b5 fix-stdc99.patch"
+sha512sums="ee50855a2fff41c07761c9f3cabdee658f72a47b71a1ad82d478bde782c7577e9280e76f8b11432a373027f0566acb4349003b654e4a6e63ec70e9b03763fe99 raspberrypi-0.20140919.tar.gz
+8092d59985d7380b533896c6f8aad6f4838e8cf414a8052c43fa4330bc07ce6be7d2d0cc3bc280f3f63b537687cb8f51c93ef608db82fe6638505d03b317581f fix-musl.patch
+1650cf7230da10d0ceedfcae170e93d2c33e799b670392a2cc1e44cf7108c9f46c47b6daa50a608bba4e1683d859d9b70eb7d2070640c956fe6c0d58a29ca89f fix-stdc99.patch"
diff --git a/testing/raspberrypi/fix-stdc99.patch b/testing/raspberrypi/fix-stdc99.patch
new file mode 100644
index 000000000..4cdda94c7
--- /dev/null
+++ b/testing/raspberrypi/fix-stdc99.patch
@@ -0,0 +1,24 @@
+--- userland-ffcc4bd7c4875b71376c4240116e251652c9bec0.orig/containers/CMakeLists.txt
++++ userland-ffcc4bd7c4875b71376c4240116e251652c9bec0/containers/CMakeLists.txt
+@@ -13,7 +13,7 @@
+
+ SET( GCC_COMPILER_FLAGS -Wall -g -O2 -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wcast-qual -Wwrite-strings -Wundef )
+ SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -Wextra )#-Wno-missing-field-initializers )
+-SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -D__STDC_VERSION__=199901L )
++SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -std=c99 )
+ SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -Wno-missing-field-initializers )
+ SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -Wno-unused-value )
+
+--- userland-ffcc4bd7c4875b71376c4240116e251652c9bec0.orig/interface/vcos/pthreads/vcos_platform.h
++++ userland-ffcc4bd7c4875b71376c4240116e251652c9bec0/interface/vcos/pthreads/vcos_platform.h
+@@ -44,6 +44,10 @@
+ extern "C" {
+ #endif
+
++#ifndef _POSIX_C_SOURCE
++#define _POSIX_C_SOURCE 199309L
++#endif
++
+ #include <pthread.h>
+ #include <semaphore.h>
+ #include <unistd.h>