summaryrefslogtreecommitdiffstats
path: root/testing/redis/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-31 13:53:04 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-31 13:53:04 +0200
commit33ccfa229d3230cdf7c48083db49ce5c2f8842f5 (patch)
tree100dba6f32adbef343f9e7b4ab6f9e1a80af9431 /testing/redis/APKBUILD
parentae10eeb740d8e4f5c4a9eddd348f9b30456ec604 (diff)
downloadaports-33ccfa229d3230cdf7c48083db49ce5c2f8842f5.tar.bz2
aports-33ccfa229d3230cdf7c48083db49ce5c2f8842f5.tar.xz
testing/redis: new aport
Advanced key-value store http://redis.googlecode.com
Diffstat (limited to 'testing/redis/APKBUILD')
-rw-r--r--testing/redis/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/testing/redis/APKBUILD b/testing/redis/APKBUILD
new file mode 100644
index 000000000..6321569a5
--- /dev/null
+++ b/testing/redis/APKBUILD
@@ -0,0 +1,60 @@
+# Contributor: V.Krishn <vkrishn4@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=redis
+pkgver=2.4.14
+pkgrel=0
+pkgdesc="Advanced key-value store"
+url="http://redis.googlecode.com"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages=""
+pkgusers="redis"
+pkggroups="redis"
+source="http://redis.googlecode.com/files/$pkgname-$pkgver.tar.gz
+ redis.initd
+ redis.logrotate
+ redis.confd"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS="$CFLAGS -std=c99"
+ make PREFIX=/usr INSTALL_BIN="$pkgdir"/usr/bin \
+ FORCE_LIBC_MALLOC=yes || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/bin
+
+ install -D -m755 "$_builddir/COPYING" \
+ "$pkgdir/usr/share/licenses/redis/COPYING" || return 1
+ install -D -m755 "$srcdir/redis.initd" "$pkgdir/etc/init.d/redis" \
+ && install -Dm644 "$srcdir/redis.logrotate" \
+ "$pkgdir/etc/logrotate.d/redis" \
+ && install -Dm644 "$srcdir/redis.confd" \
+ "$pkgdir/etc/conf.d/redis" \
+ || return 1
+ sed -i -e 's|daemonize no|daemonize yes|' \
+ -e 's|dir \./|dir /var/lib/redis/|' \
+ -e 's|logfile stdout|logfile /var/log/redis.log|' \
+ $_builddir/redis.conf || return 1
+ install -D -m644 "$_builddir/redis.conf" "$pkgdir/etc/redis.conf" \
+ || retrun 1
+
+ make INSTALL_BIN="$pkgdir/usr/bin" PREFIX=/usr install || return 1
+}
+
+
+md5sums="1bc8f833b955ef119d643da08084433f redis-2.4.14.tar.gz
+9aee4f445f4f6fcbc4475691f12e62af redis.initd
+9e2d75b7a9dc421122d673fe520ef17f redis.logrotate
+91c1be756ef41ab3a47a3573100bb335 redis.confd"