summaryrefslogtreecommitdiffstats
path: root/testing/rinse
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2013-04-25 14:21:49 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2013-04-25 14:21:49 -0500
commit221ec6db135e7fbecabb7cb3992de0a0cf195c59 (patch)
treec2b25bac11637e78a560059051b370960a396fb2 /testing/rinse
parent8066c7dee0d672fb053049276aaee402d56fb5cc (diff)
downloadaports-221ec6db135e7fbecabb7cb3992de0a0cf195c59.tar.bz2
aports-221ec6db135e7fbecabb7cb3992de0a0cf195c59.tar.xz
testing/rinse: set /etc/rpm/platform properly on redhat derivatives
Diffstat (limited to 'testing/rinse')
-rw-r--r--testing/rinse/APKBUILD14
-rw-r--r--testing/rinse/rinse-set-rpm-platform.patch100
2 files changed, 109 insertions, 5 deletions
diff --git a/testing/rinse/APKBUILD b/testing/rinse/APKBUILD
index 8b5e4fc0c..e8936e4d0 100644
--- a/testing/rinse/APKBUILD
+++ b/testing/rinse/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=rinse
pkgver=2.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="A RPM chroot bootstrapping tool"
url="http://www.steve.org.uk/Software/rinse/"
arch="noarch"
@@ -14,7 +14,8 @@ install=""
subpackages="$pkgname-doc"
source="http://www.steve.org.uk/Software/rinse/rinse-$pkgver.tar.gz
rinse-posix-cpio-use.patch
- rinse-device-nodes.patch"
+ rinse-device-nodes.patch
+ rinse-set-rpm-platform.patch"
_builddir="$srcdir"/rinse-$pkgver
prepare() {
@@ -38,10 +39,13 @@ package() {
md5sums="1221942846f4caa6e621cfc85f759841 rinse-2.0.1.tar.gz
6761f834b3f50bded544021ccb90c700 rinse-posix-cpio-use.patch
-6a6092323c1973832f5c050d37265d99 rinse-device-nodes.patch"
+6a6092323c1973832f5c050d37265d99 rinse-device-nodes.patch
+e292f3192df193924f86ef1f20bee745 rinse-set-rpm-platform.patch"
sha256sums="74b1149cb6f12c1bd51e371e5decf4820489535afa9b93900780817cbae7f96b rinse-2.0.1.tar.gz
f869904261add72b2e6a50f910fc79fae44b68df617c8d0d1e1e02d99c77e165 rinse-posix-cpio-use.patch
-dfb972611d74889902d1f25edf6bd172aaa8ef62c352a5e966c2892c568171e8 rinse-device-nodes.patch"
+dfb972611d74889902d1f25edf6bd172aaa8ef62c352a5e966c2892c568171e8 rinse-device-nodes.patch
+e6d789e0fc67658eac0b1c11ae32e5407aaf2eb09fa479b5e42f94a28526f8df rinse-set-rpm-platform.patch"
sha512sums="4d6284dfd5bdaac1c2578222203c5dd1bfcd325b756583238c45a064da2345ed75615461464845d721026d3ee1b2bab55f138c9fd5d911f7b41a4e7af5ab9cd8 rinse-2.0.1.tar.gz
a8ff20b382fa05bf921d1a99fcf7f1e147a63ff7b2c1d04c312ac9d1148d8acb07c56a016176f081a6c2c6797d31a5bd3607b1d891517888931c42bde9a58465 rinse-posix-cpio-use.patch
-9bca1bbbe11453d80f06d330af5695a874240a274ea671f30fd3383f2a88e5e0c73a167aa4ac10f3fde6f9df0cda5678ef436de3ed111a16b008128aafb2a196 rinse-device-nodes.patch"
+9bca1bbbe11453d80f06d330af5695a874240a274ea671f30fd3383f2a88e5e0c73a167aa4ac10f3fde6f9df0cda5678ef436de3ed111a16b008128aafb2a196 rinse-device-nodes.patch
+4e50dafbdd39d1f057a459173e0eac355c0ed592e9d7741a479610915b65ae2e2872ede776fbaca332a8aec20ef94c70ca3b77639670827647634fe276d8731a rinse-set-rpm-platform.patch"
diff --git a/testing/rinse/rinse-set-rpm-platform.patch b/testing/rinse/rinse-set-rpm-platform.patch
new file mode 100644
index 000000000..a5eae642b
--- /dev/null
+++ b/testing/rinse/rinse-set-rpm-platform.patch
@@ -0,0 +1,100 @@
+--- rinse-2.0.1.orig/scripts/centos-5/post-install.sh
++++ rinse-2.0.1/scripts/centos-5/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ]; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+
+--- rinse-2.0.1.orig/scripts/centos-6/post-install.sh
++++ rinse-2.0.1/scripts/centos-6/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ]; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+
+--- rinse-2.0.1.orig/scripts/rhel-5/post-install.sh
++++ rinse-2.0.1/scripts/rhel-5/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ] ; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+
+--- rinse-2.0.1.orig/scripts/slc-5/post-install.sh
++++ rinse-2.0.1/scripts/slc-5/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ] ; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+
+--- rinse-2.0.1.orig/scripts/slc-6/post-install.sh
++++ rinse-2.0.1/scripts/slc-6/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ] ; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+