summaryrefslogtreecommitdiffstats
path: root/testing/shadow
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-07-30 14:26:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-07-30 14:26:26 +0000
commit521a66392c56173f7c228717323170866245ea19 (patch)
treec3c138a9da2b30cacd0389f170decda3d63ea22c /testing/shadow
parent524b4ea9b8c32f8c304eeaf084fd46bf822df8e3 (diff)
downloadaports-521a66392c56173f7c228717323170866245ea19.tar.bz2
aports-521a66392c56173f7c228717323170866245ea19.tar.xz
testing/shadow: moved from unmaintained
Diffstat (limited to 'testing/shadow')
-rw-r--r--testing/shadow/APKBUILD62
-rw-r--r--testing/shadow/login.pamd6
-rw-r--r--testing/shadow/shadow.post-deinstall4
-rw-r--r--testing/shadow/shadow.post-upgrade4
4 files changed, 76 insertions, 0 deletions
diff --git a/testing/shadow/APKBUILD b/testing/shadow/APKBUILD
new file mode 100644
index 000000000..d5be67a7f
--- /dev/null
+++ b/testing/shadow/APKBUILD
@@ -0,0 +1,62 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=shadow
+pkgver=4.2.1
+pkgrel=0
+pkgdesc="PAM-using login and passwd utilities (usermod / useradd / newuidmap etc)"
+url="http://pkg-shadow.alioth.debian.org/"
+arch="all"
+license="GPL"
+depends=
+depends_dev="linux-pam-dev"
+makedepends="$depends_dev"
+install="$pkgname.post-upgrade $pkgname.post-deinstall"
+subpackages="$pkgname-doc"
+source="http://pkg-shadow.alioth.debian.org/releases/shadow-$pkgver.tar.xz
+ login.pamd"
+
+_builddir="$srcdir"/shadow-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --without-nscd \
+ --disable-nls \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ # do not install these pam.d files they are broken and outdated
+ rm "$pkgdir"/etc/pam.d/*
+
+ # however, install our own for login
+ cp "$srcdir"/login.pamd "$pkgdir"/etc/pam.d/login
+
+ # /etc/login.defs is not very useful - replace it with a blank file
+ rm "$pkgdir"/etc/login.defs
+ touch "$pkgdir"/etc/login.defs
+}
+
+md5sums="2bfafe7d4962682d31b5eba65dba4fc8 shadow-4.2.1.tar.xz
+72dfc077a61ab7163e312640cc98bba8 login.pamd"
+sha256sums="3b0893d1476766868cd88920f4f1231c4795652aa407569faff802bcda0f3d41 shadow-4.2.1.tar.xz
+c0d0f2f77133b0663c5a578afeba45d5a9c703ff6f3f6aba3727dfe01877dac0 login.pamd"
+sha512sums="7a14bf8e08126f0402e37b6e4c559615ced7cf829e39156d929ed05cd8813de48a77ff1f7f6fe707da04cf662a2e9e84c22d63d88dd1ed13f935fde594db95f0 shadow-4.2.1.tar.xz
+46a6f83f3698e101b58b8682852da749619412f75dfa85cecad03d0847f6c3dc452d984510db7094220e4570a0565b83b0556e16198ad894a3ec84b3e513d58d login.pamd"
diff --git a/testing/shadow/login.pamd b/testing/shadow/login.pamd
new file mode 100644
index 000000000..ad4555809
--- /dev/null
+++ b/testing/shadow/login.pamd
@@ -0,0 +1,6 @@
+# /bin/login opens an interactive session.
+
+auth include base-auth
+account include base-account
+password include base-password
+session include base-session
diff --git a/testing/shadow/shadow.post-deinstall b/testing/shadow/shadow.post-deinstall
new file mode 100644
index 000000000..dd117e5d8
--- /dev/null
+++ b/testing/shadow/shadow.post-deinstall
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+busybox --install -s
+
diff --git a/testing/shadow/shadow.post-upgrade b/testing/shadow/shadow.post-upgrade
new file mode 100644
index 000000000..dd117e5d8
--- /dev/null
+++ b/testing/shadow/shadow.post-upgrade
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+busybox --install -s
+