summaryrefslogtreecommitdiffstats
path: root/testing/tbl/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-06 13:06:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-06 13:06:21 +0000
commit37a97cda850a8ac1738db7887cefb15d4cc39cc5 (patch)
tree3b72a64af9b12dff2bcaac36c30b9ad30e03c959 /testing/tbl/APKBUILD
parent979d3c10b6dc623a4c17ba4592c7ff0ff01c5ec8 (diff)
downloadaports-37a97cda850a8ac1738db7887cefb15d4cc39cc5.tar.bz2
aports-37a97cda850a8ac1738db7887cefb15d4cc39cc5.tar.xz
testing/tbl: new aport
Utility to format tables for troff http://tbl.bsd.lv/
Diffstat (limited to 'testing/tbl/APKBUILD')
-rw-r--r--testing/tbl/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/tbl/APKBUILD b/testing/tbl/APKBUILD
new file mode 100644
index 000000000..de2286ea6
--- /dev/null
+++ b/testing/tbl/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=tbl
+pkgver=0.1.5
+pkgrel=0
+pkgdesc="Utility to format tables for troff"
+url="http://tbl.bsd.lv/"
+license="ISC"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-doc"
+source="http://tbl.bsd.lv/snapshots/tbl-$pkgver.tar.gz
+ tbl-install.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr MANDIR=/usr/share/man install
+}
+
+md5sums="633edde9037b0a01b045b05e655ee7c9 tbl-0.1.5.tar.gz
+e4f29245b659de9814ff1a7a1c98ffb2 tbl-install.patch"