summaryrefslogtreecommitdiffstats
path: root/testing/thunar-media-tags-plugin/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-14 10:35:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-14 10:35:45 +0000
commit5486d4bb1cd6d9b9abb79989dafdc9abb29664e9 (patch)
tree2f0f7b6b70b17afa62a648a7ac510655089a882e /testing/thunar-media-tags-plugin/APKBUILD
parentfb519d2382dac018d993f4ea8cc526a81fc3b094 (diff)
downloadaports-5486d4bb1cd6d9b9abb79989dafdc9abb29664e9.tar.bz2
aports-5486d4bb1cd6d9b9abb79989dafdc9abb29664e9.tar.xz
testing/thunar-media-tags-plugin: new aport
Media Tags plugin for the Thunar file manager http://goodies.xfce.org/projects/thunar-plugins/thunar-media-tags-plugin
Diffstat (limited to 'testing/thunar-media-tags-plugin/APKBUILD')
-rw-r--r--testing/thunar-media-tags-plugin/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/thunar-media-tags-plugin/APKBUILD b/testing/thunar-media-tags-plugin/APKBUILD
new file mode 100644
index 000000000..5a6313345
--- /dev/null
+++ b/testing/thunar-media-tags-plugin/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=thunar-media-tags-plugin
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="Media Tags plugin for the Thunar file manager"
+url="http://goodies.xfce.org/projects/thunar-plugins/thunar-media-tags-plugin"
+arch="all"
+license="GPLv2+"
+depends=""
+makedepends="thunar-dev xfce4-dev-tools taglib-dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://goodies.xfce.org/releases/thunar-media-tags-plugin/thunar-media-tags-plugin-$pkgver.tar.bz2
+ 01_port-to-thunarx-2.patch
+ 02_port-to-exo-1.patch
+ 03_fix-crash-with-ogg-video-files.patch
+ 04_fix-implicit-dso-linking.patch"
+
+_builddir="$srcdir"/thunar-media-tags-plugin-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ xdt-autogen
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/xfce4 \
+ --disable-static \
+ --sysconfdir=/etc \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/thunarx-2/*.la
+}
+
+md5sums="8a95f0ea4df6f757c1c94eb5442d2ff5 thunar-media-tags-plugin-0.1.2.tar.bz2
+479843c634c516afb405ebdd72f37203 01_port-to-thunarx-2.patch
+5af37349b7d6d1b0180e49c1d86f9d8f 02_port-to-exo-1.patch
+d83ec2e224db216f90e9035b442e1e73 03_fix-crash-with-ogg-video-files.patch
+b6956747e247de938bc0970ba78cd8bf 04_fix-implicit-dso-linking.patch"