summaryrefslogtreecommitdiffstats
path: root/testing/unetbootin
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2013-05-28 06:42:23 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2013-05-28 06:42:40 -0500
commit59e25fde062576dee258e23b74097a5a747ba329 (patch)
treea24eb1af33ca0ecbcf37e3f889cacb130c279977 /testing/unetbootin
parentc1832278d7abd29ce634cd25d1b5f1394ba80bce (diff)
downloadaports-59e25fde062576dee258e23b74097a5a747ba329.tar.bz2
aports-59e25fde062576dee258e23b74097a5a747ba329.tar.xz
testing/unetbootin: new aport
Diffstat (limited to 'testing/unetbootin')
-rw-r--r--testing/unetbootin/APKBUILD53
-rw-r--r--testing/unetbootin/allow-ntfs.patch20
2 files changed, 73 insertions, 0 deletions
diff --git a/testing/unetbootin/APKBUILD b/testing/unetbootin/APKBUILD
new file mode 100644
index 000000000..d2fc9481d
--- /dev/null
+++ b/testing/unetbootin/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=unetbootin
+pkgver=583
+pkgrel=0
+pkgdesc="tool for building USB install media"
+url="http://unetbootin.sourceforge.net/"
+arch="all"
+license="GPL"
+depends="syslinux p7zip"
+depends_dev=""
+makedepends="qt-dev $depends_dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://unetbootin.sourceforge.net/unetbootin-source-clean-latest.tar.gz
+ allow-ntfs.patch"
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ lupdate unetbootin.pro
+ lrelease unetbootin.pro
+ qmake "DEFINES += NOSTATIC" "RESOURCES -= unetbootin.qrc"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 "$srcdir"/unetbootin "$pkgdir"/usr/bin/unetbootin
+}
+
+lang() {
+ arch="noarch"
+ cd "$_builddir"
+ install -D -m644 "$srcdir"/unetbootin_*.qm "$subpkgdir"/usr/share/unetbootin
+}
+
+md5sums="ad35d814b8f5d9bf4a3563cacbf20296 unetbootin-source-clean-latest.tar.gz
+a7d9ea8ed464600bc3d5b018ad6024f6 allow-ntfs.patch"
+sha256sums="0fba985a6d4a7a4c388cb99d100cb46fbd9bbae831501ad887a8d5f148a24029 unetbootin-source-clean-latest.tar.gz
+7e1153938a868d390bb0b54ade22299696e2d5c7a9d1347ecbe9d33d097e0b7b allow-ntfs.patch"
+sha512sums="1106938218e965f6b6e7a86a8998642e824c6fb2a5b0cf79869151d7a768daa61a18c7308e646965315f7c83390e6a8d9e077c13ce6e94e748b77b10115b0bab unetbootin-source-clean-latest.tar.gz
+7b5d415a226356697d7e4ce18d8e9cc4e7c5357ef94fc7a063a320f1f2fa5d03109bd399fafe4565144327643284d3b3ddbf57568cccf34f81e0bd61e151208b allow-ntfs.patch"
diff --git a/testing/unetbootin/allow-ntfs.patch b/testing/unetbootin/allow-ntfs.patch
new file mode 100644
index 000000000..d8e72c191
--- /dev/null
+++ b/testing/unetbootin/allow-ntfs.patch
@@ -0,0 +1,20 @@
+--- src.orig/unetbootin.cpp
++++ src/unetbootin.cpp
+@@ -572,7 +572,7 @@
+ {
+ if (!volidcommand.isEmpty())
+ {
+- if (QString(callexternapp(volidcommand, QString("-t %2").arg(usbfileinfoL.at(i).canonicalFilePath()))).contains(QRegExp("(vfat|ext2|ext3|ext4)")))
++ if (QString(callexternapp(volidcommand, QString("-t %2").arg(usbfileinfoL.at(i).canonicalFilePath()))).contains(QRegExp("(vfat|ntfs|ext2|ext3|ext4)")))
+ fulldrivelist.append(usbfileinfoL.at(i).canonicalFilePath());
+ }
+ else
+@@ -580,7 +580,7 @@
+ QString tstrblk = QString(callexternapp(blkidcommand, QString("-s TYPE %2").arg(usbfileinfoL.at(i).canonicalFilePath())));
+ if (tstrblk.contains('='))
+ {
+- if (tstrblk.section('=', -1, -1).remove('"').contains(QRegExp("(vfat|ext2|ext3|ext4)")))
++ if (tstrblk.section('=', -1, -1).remove('"').contains(QRegExp("(vfat|ntfs|ext2|ext3|ext4)")))
+ fulldrivelist.append(usbfileinfoL.at(i).canonicalFilePath());
+ }
+ }