summaryrefslogtreecommitdiffstats
path: root/testing/unpaper/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 15:08:48 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 15:08:48 +0200
commit86591e0d45277b720435fca5babaa5d21c507b9c (patch)
tree30bc7c010506e2d1c63a0541aaec055ab453dd2b /testing/unpaper/APKBUILD
parent12cd1634f3a45a14621f4b408859a8d67f195cfa (diff)
downloadaports-86591e0d45277b720435fca5babaa5d21c507b9c.tar.bz2
aports-86591e0d45277b720435fca5babaa5d21c507b9c.tar.xz
Revert "testing/unpaper: upgrade to 0.4.2"
Diffstat (limited to 'testing/unpaper/APKBUILD')
-rw-r--r--testing/unpaper/APKBUILD24
1 files changed, 7 insertions, 17 deletions
diff --git a/testing/unpaper/APKBUILD b/testing/unpaper/APKBUILD
index b86aa77a0..860bb3425 100644
--- a/testing/unpaper/APKBUILD
+++ b/testing/unpaper/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=unpaper
-pkgver=0.4.2
+pkgver=0.3
pkgrel=0
pkgdesc="Post-processing scanned and photocopied book pages"
url="http://unpaper.berlios.de/"
@@ -12,28 +12,18 @@ depends_dev=""
makedepends=""
install=""
subpackages=""
-source="https://www.flameeyes.eu/files/$pkgname-$pkgver.tar.xz"
-
+source="http://download.berlios.de/$pkgname/$pkgname-bin-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
+
build() {
cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- || return 1
- make || return 1
+ gcc $RPM_OPT_FLAGS -o src/unpaper src/unpaper.c -lm || return 1
}
package() {
cd "$_builddir"
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
+ install -m755 -D "$_builddir"/src/$pkgname \
+ "$pkgdir"/usr/bin/$pkgname || return 1
}
-md5sums="b4f9890e34e6fa13f24f3ced3a06b618 unpaper-0.4.2.tar.xz"
-sha256sums="93743a7c9c85463dceed2520b3f5a6cc3f94a289a670cde753bba0ec8035d453 unpaper-0.4.2.tar.xz"
-sha512sums="a64c5c5ba437e9718120fee66b9a63cb59558a9c09047ce6ab88b38d6a34ff62e37ffa6670c5c2fd491351092f775cd01668c8b8cd353fac80db6b2dfacdc79c unpaper-0.4.2.tar.xz"
+md5sums="0748137e67fa5796474716a096a82723 unpaper-bin-0.3.tar.gz"