summaryrefslogtreecommitdiffstats
path: root/testing/urlwatch
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-01-30 03:14:26 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-17 13:33:13 +0000
commited4b275fe1dcefd3a8d817dcdff879e1a27ef21e (patch)
tree95e52edbfad3c79fb5555104f3432f93920870f1 /testing/urlwatch
parent38b55c687038ef865a411f734b643b79bed5a368 (diff)
downloadaports-ed4b275fe1dcefd3a8d817dcdff879e1a27ef21e.tar.bz2
aports-ed4b275fe1dcefd3a8d817dcdff879e1a27ef21e.tar.xz
testing/urlwatch: new aport
This script is intended to help you watch URLs and get notified (via email or in your terminal) of any changes. The change notification will include the URL that has changed and a unified diff of what has changed. The script supports the use of a filtering hook function to strip trivially-varying elements of a webpage. Basic features * Simple configuration (text file, one URL per line) * Easily hackable (clean Python implementation) * Can run as a cronjob and mail changes to you * Always outputs only plaintext - no HTML mails :) * Supports removing noise (always-changing website parts) * Example hooks to filter content in Python http://thpinfo.com/2008/urlwatch/
Diffstat (limited to 'testing/urlwatch')
-rw-r--r--testing/urlwatch/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/urlwatch/APKBUILD b/testing/urlwatch/APKBUILD
new file mode 100644
index 000000000..8927ac8a1
--- /dev/null
+++ b/testing/urlwatch/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=urlwatch
+pkgver=1.14
+pkgrel=0
+pkgdesc="A tool for monitoring webpages for updates"
+url="http://thpinfo.com/2008/urlwatch/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://thp.io/2008/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="6bff9dab50fe4c45521d0b8e36d604a5 urlwatch-1.14.tar.gz"