summaryrefslogtreecommitdiffstats
path: root/testing/usbip-utils
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-06-13 11:29:52 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-06-13 11:29:52 +0000
commit3a8de4c9a71a2a1ed54ca95a980e857c37616985 (patch)
tree6f91054096ab803e8a26cd3ec3057f4e02fd19b6 /testing/usbip-utils
parentf916d4157891ec0576a6b70b60bcaabae54f30c4 (diff)
downloadaports-3a8de4c9a71a2a1ed54ca95a980e857c37616985.tar.bz2
aports-3a8de4c9a71a2a1ed54ca95a980e857c37616985.tar.xz
testing/usbip-utils: package remove until fixed in the upstream
Diffstat (limited to 'testing/usbip-utils')
-rw-r--r--testing/usbip-utils/APKBUILD45
-rw-r--r--testing/usbip-utils/strnlen-uclibc.patch9
2 files changed, 0 insertions, 54 deletions
diff --git a/testing/usbip-utils/APKBUILD b/testing/usbip-utils/APKBUILD
deleted file mode 100644
index f1e473860..000000000
--- a/testing/usbip-utils/APKBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
-pkgname=usbip-utils
-_pkgname=linux-stable
-pkgver=1.1.1
-_pkgver=ca89df9
-pkgrel=1
-pkgdesc="usbip for linux-stable from kernel.org"
-url="http://git.kernel.org/?p=linux/kernel/git/stable/linux-stable.git;a=summary"
-arch="all"
-license="GPL"
-depends=""
-depends_dev="sysfsutils-dev automake autoconf libtool glib-dev"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev"
-source="saveas-http://git.kernel.org/?p=linux/kernel/git/stable/linux-stable.git;a=snapshot;h=ca89df931f296e469ed748da0a91c0af43e108d2;sf=tgz/usbip.tgz
- strnlen-uclibc.patch"
-_builddir="$srcdir"/$_pkgname-$_pkgver
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 src/utils.c < "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./autogen.sh || return 1
- ./configure --prefix=/usr
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm "$pkgdir"/usr/lib/*.la
-}
-
-md5sums="152d41fbc8b1fc8a9e2cc2e873892d38 usbip.tgz
-ddf740926a40d34d1808bb55587b35e1 strnlen-uclibc.patch"
diff --git a/testing/usbip-utils/strnlen-uclibc.patch b/testing/usbip-utils/strnlen-uclibc.patch
deleted file mode 100644
index d670ed69c..000000000
--- a/testing/usbip-utils/strnlen-uclibc.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-@@ -35,7 +35,7 @@
- struct sysfs_attribute *match_busid_attr;
- int rc, ret = 0;
-
-- if (strnlen(busid, SYSFS_BUS_ID_SIZE) > SYSFS_BUS_ID_SIZE - 1) {
-+ if (strlen(busid) > SYSFS_BUS_ID_SIZE - 1) {
- dbg("busid is too long");
- return -1;
- }