summaryrefslogtreecommitdiffstats
path: root/testing/vlc/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-01-28 18:49:05 +0200
committerTimo Teräs <timo.teras@iki.fi>2012-01-28 18:53:32 +0200
commiteb8f81e80242e9359ef9e188a595912822505413 (patch)
tree1fc5c49fca8a79e0918031730cae306030f072df /testing/vlc/APKBUILD
parent328d84a74324de66100c5d26db38646437dede52 (diff)
downloadaports-eb8f81e80242e9359ef9e188a595912822505413.tar.bz2
aports-eb8f81e80242e9359ef9e188a595912822505413.tar.xz
testing/vlc: copied form main and upgraded to 2.0.0-rc1
* qt4 and skins2 gui interfaces are also enabled (to subpkg vlc-xorg)
Diffstat (limited to 'testing/vlc/APKBUILD')
-rw-r--r--testing/vlc/APKBUILD204
1 files changed, 204 insertions, 0 deletions
diff --git a/testing/vlc/APKBUILD b/testing/vlc/APKBUILD
new file mode 100644
index 000000000..450d6f8a8
--- /dev/null
+++ b/testing/vlc/APKBUILD
@@ -0,0 +1,204 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=vlc
+pkgver=2.0.0_rc1
+_pkgver=${pkgver/_/-}
+pkgrel=0
+pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
+pkgusers="vlc"
+pkggroups="vlc"
+url="http://www.videolan.org/vlc/"
+arch="all"
+license="GPL-2"
+triggers="$pkgname.trigger=/usr/lib/vlc/plugins"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-xorg $pkgname-daemon"
+#depends="fluidsynth zvbi lirc-utils libdca
+# libproxy libdvdnav>=4.1.3 libcddb smbclient
+# libmatroska libmpcdec
+# qt libmodplug ttf-dejavu"
+depends="ttf-dejavu"
+makedepends="
+ a52dec-dev
+ alsa-lib-dev
+ automake
+ autoconf
+ avahi-dev
+ libtool
+ dbus-dev
+ faad2-dev
+ ffmpeg-dev
+ flac-dev
+ freetype-dev
+ fribidi-dev
+ gtk+-dev
+ libdc1394-dev
+ libdvbpsi-dev
+ libgcrypt-dev
+ libice-dev
+ libiconv-dev
+ libmad-dev
+ libmpeg2-dev
+ libnotify-dev
+ libogg-dev
+ libraw1394-dev
+ libshout-dev
+ libsm-dev
+ libtheora-dev
+ libvorbis-dev
+ libx11-dev
+ libxext-dev
+ libxinerama-dev
+ libxpm-dev
+ libxv-dev
+ live-media-dev
+ lua-dev
+ ncurses-dev
+ mesa-dev
+ pkgconfig
+ qt-dev
+ sdl-dev
+ speex-dev
+ sysfsutils-dev
+ taglib-dev
+ v4l-utils-dev
+ x264-dev
+ xcb-util-renderutil-dev
+ xcb-util-keysyms-dev
+ "
+source="http://download.videolan.org/pub/videolan/testing/$pkgname-$_pkgver/$pkgname-$_pkgver.tar.xz
+ uclibc-inhibit-spawn.patch
+ uclibc-no-xscreensaver.patch
+ uclibc3.patch
+ vlc.trigger
+ "
+# uclibc-libcompat.patch
+# vlc-1.1.7-disable-cache-gen.patch
+
+_builddir="$srcdir"/$pkgname-$_pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac;
+ done
+ sed -i -e "/^libxscreensaver_plugin_la_SOURCES/s/^/#/" modules/misc/Modules.am
+ ./bootstrap
+}
+
+build ()
+{
+ cd "$_builddir"
+ sed -i -e 's:/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf:/usr/share/fonts/TTF/DejaVuSerif-Bold.ttf:' modules/misc/freetype.c
+
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE"
+
+ ./configure --prefix=/usr \
+ --disable-mmx \
+ --disable-nls \
+ --disable-optimizations \
+ --disable-rpath \
+ --enable-a52 \
+ --enable-avcodec \
+ --enable-avformat \
+ --enable-dbus \
+ --enable-dbus-control \
+ --enable-dc1394 \
+ --enable-dvbpsi \
+ --enable-faad \
+ --enable-flac \
+ --enable-httpd \
+ --enable-live555 \
+ --enable-merge-ffmpeg \
+ --enable-ncurses \
+ --enable-qt4 \
+ --enable-realrtsp \
+ --enable-sdl \
+ --enable-shout \
+ --enable-skins2 \
+ --enable-speex \
+ --enable-sout \
+ --enable-taglib \
+ --enable-theora \
+ --enable-v4l2 \
+ --enable-vlm \
+ --enable-vorbis \
+ --enable-wma-fixed \
+ --enable-xvideo \
+ || return 1
+
+# --enable-dvdread \
+# --enable-dvdnav \
+# --enable-dvb \
+# --enable-snapshot \
+# --enable-hal \
+# --enable-lirc \
+# --enable-pvr \
+
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+# for res in 16 32 48 128; do
+# install -D -m644 share/vlc${res}x${res}.png \
+# "$pkgdir"/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png || return 1
+# done
+ # delete cache as it's autocreated by trigger
+ rm -rf "$pkgdir"/usr/lib/vlc/plugins/plugins.dat
+ # delete unneeded mozilla and kde support files
+ rm -rf "$pkgdir"/usr/lib/mozilla
+ rm -rf "$pkgdir"/usr/share/kde4
+ find "$pkgdir" -name '*.la' -delete
+}
+
+_mv() {
+ local dir=${1%/*}
+ mkdir -p "$subpkgdir"/$dir
+ mv "$1" "$subpkgdir"/$dir/
+}
+
+xorg() {
+ pkgdesc="Video LAN X.org support"
+ depends="xdg-utils vlc>=2.0.0_rc1-r0"
+
+ # scan for elf files that directly or indirectly depends on
+ # libX* libraries
+ cd "$pkgdir"
+ for i in $(find -type f ); do
+ if ldd $i 2>/dev/null | grep -E -q "libX|x11|libxcb"; then
+ echo $i | grep libavcodec_plugin.so || _mv "$i" || return 1
+ fi
+ done
+
+ mkdir -p "$subpkgdir"/usr/share/vlc
+ mv "$pkgdir"/usr/share/applications \
+ "$pkgdir"/usr/share/icons \
+ "$subpkgdir"/usr/share/
+
+ mv "$pkgdir"/usr/share/vlc/skins2 \
+ "$subpkgdir"/usr/share/vlc
+}
+
+daemon() {
+ pkgdesc="Support for running VLC as a daemon"
+ install="vlc-daemon.pre-install"
+ arch="noarch"
+ depends="vlc>=2.0.0_rc1-r0"
+
+ mkdir -p "$subpkgdir"
+ cd "$pkgdir"
+ install -D -m755 ../../vlc.initd $subpkgdir/etc/init.d/vlc
+ install -D -m664 ../../vlc.confd $subpkgdir/etc/conf.d/vlc
+ install -d -o vlc -g vlc "$subpkgdir"/var/log/vlc
+}
+
+md5sums="8c4bfbc5e79ff0bdfff572d53b03a92a vlc-2.0.0-rc1.tar.xz
+28349b8239fdd6987fbe0ca2c758517f uclibc-inhibit-spawn.patch
+b84c5a9121440b6a1dcf28792d783eb8 uclibc-no-xscreensaver.patch
+94f11ec8394775018222781a0c875444 uclibc3.patch
+ddbd40bd72fedc1449be45588aea5d66 vlc.trigger"