summaryrefslogtreecommitdiffstats
path: root/testing/xulrunner
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-12 10:42:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-12 10:42:15 +0000
commitcd46eba6f617f9d99d6485c14d2375fb4bdd68ca (patch)
tree0a28dbf530e1bf63dc2fae356ea0c134988207d1 /testing/xulrunner
parentec35bbd33549a6d71640b9b9e77d1a9142e8fbd8 (diff)
downloadaports-cd46eba6f617f9d99d6485c14d2375fb4bdd68ca.tar.bz2
aports-cd46eba6f617f9d99d6485c14d2375fb4bdd68ca.tar.xz
main/firefox,xulrunner: upgrade to 10.0.1
Diffstat (limited to 'testing/xulrunner')
-rw-r--r--testing/xulrunner/0002-Use-C99-math-isfinite.patch43
-rw-r--r--testing/xulrunner/0003-xulrunner-jemalloc-aslr.patch67
-rw-r--r--testing/xulrunner/0004-xulrunner-malloc_usable_size.patch34
-rw-r--r--testing/xulrunner/APKBUILD112
-rw-r--r--testing/xulrunner/ff9-aslr-fix.patch40
-rw-r--r--testing/xulrunner/mozconfig38
6 files changed, 0 insertions, 334 deletions
diff --git a/testing/xulrunner/0002-Use-C99-math-isfinite.patch b/testing/xulrunner/0002-Use-C99-math-isfinite.patch
deleted file mode 100644
index 3d85a6928..000000000
--- a/testing/xulrunner/0002-Use-C99-math-isfinite.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From cdb9db4c1c593dbe22db4f389a62fce034f31f2d Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 25 Nov 2011 08:30:51 +0000
-Subject: [PATCH 2/4] Use C99 math isfinite
-
----
- js/src/ctypes/CTypes.cpp | 2 +-
- xpcom/ds/nsMathUtils.h | 6 +++++-
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/js/src/ctypes/CTypes.cpp b/js/src/ctypes/CTypes.cpp
-index 5c0f886..a3b1ae6 100644
---- a/js/src/ctypes/CTypes.cpp
-+++ b/js/src/ctypes/CTypes.cpp
-@@ -467,7 +467,7 @@ static inline bool FloatIsFinite(jsdouble f) {
- #ifdef WIN32
- return _finite(f) != 0;
- #else
-- return finite(f);
-+ return isfinite(f);
- #endif
- }
-
-diff --git a/xpcom/ds/nsMathUtils.h b/xpcom/ds/nsMathUtils.h
-index 21ffbec..2e80476 100644
---- a/xpcom/ds/nsMathUtils.h
-+++ b/xpcom/ds/nsMathUtils.h
-@@ -131,7 +131,11 @@ inline NS_HIDDEN_(bool) NS_finite(double d)
- // NOTE: '!!' casts an int to bool without spamming MSVC warning C4800.
- return !!_finite(d);
- #else
-- return finite(d);
-+#ifdef _GLIBCXX_CMATH
-+ return std::isfinite(d);
-+#else
-+ return isfinite(d);
-+#endif
- #endif
- }
-
---
-1.7.7.4
-
diff --git a/testing/xulrunner/0003-xulrunner-jemalloc-aslr.patch b/testing/xulrunner/0003-xulrunner-jemalloc-aslr.patch
deleted file mode 100644
index 6784b13e7..000000000
--- a/testing/xulrunner/0003-xulrunner-jemalloc-aslr.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 88bb9f90ec1e4b43fb78596c8ff7577c92592eb4 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 25 Nov 2011 08:36:52 +0000
-Subject: [PATCH 3/4] xulrunner: jemalloc aslr
-
----
- memory/jemalloc/jemalloc.c | 33 ++++++++++++++++++++++-----------
- 1 files changed, 22 insertions(+), 11 deletions(-)
-
-diff --git a/memory/jemalloc/jemalloc.c b/memory/jemalloc/jemalloc.c
-index ad7c450..91de92c 100644
---- a/memory/jemalloc/jemalloc.c
-+++ b/memory/jemalloc/jemalloc.c
-@@ -410,7 +410,7 @@ void *_mmap(void *addr, size_t length, int prot, int flags,
- static const bool __isthreaded = true;
- #endif
-
--#if defined(MOZ_MEMORY_SOLARIS) && defined(MAP_ALIGN) && !defined(JEMALLOC_NEVER_USES_MAP_ALIGN)
-+#if defined(MOZ_MEMORY_SOLARIS) || defined(MOZ_MEMORY_LINUX) || defined(MOZ_MEMORY_BSD)
- #define JEMALLOC_USES_MAP_ALIGN /* Required on Solaris 10. Might improve performance elsewhere. */
- #endif
-
-@@ -2181,20 +2181,31 @@ pages_map_align(size_t size, int pfd, size_t alignment)
- * We don't use MAP_FIXED here, because it can cause the *replacement*
- * of existing mappings, and we only want to create new mappings.
- */
--#ifdef MALLOC_PAGEFILE
-- if (pfd != -1) {
-- ret = mmap((void *)alignment, size, PROT_READ | PROT_WRITE, MAP_PRIVATE |
-- MAP_NOSYNC | MAP_ALIGN, pfd, 0);
-- } else
--#endif
-- {
-- ret = mmap((void *)alignment, size, PROT_READ | PROT_WRITE, MAP_PRIVATE |
-- MAP_NOSYNC | MAP_ALIGN | MAP_ANON, -1, 0);
-- }
-+ ret = mmap(NULL, size + alignment, PROT_READ | PROT_WRITE, MAP_PRIVATE |
-+ MAP_NOSYNC| MAP_ANON, -1, 0);
- assert(ret != NULL);
-
- if (ret == MAP_FAILED)
- ret = NULL;
-+ else {
-+ uintptr_t aligned_ret;
-+ size_t extra_size;
-+
-+ aligned_ret = (uintptr_t)ret + alignment - 1;
-+ aligned_ret &= ~(alignment - 1);
-+ extra_size = aligned_ret - (uintptr_t)ret;
-+ munmap(ret, extra_size);
-+ munmap(ret + extra_size + size, alignment - extra_size);
-+ ret = (void *)aligned_ret;
-+#ifdef MALLOC_PAGEFILE
-+ if (pfd != -1) {
-+ ret = mmap(ret, size, PROT_READ | PROT_WRITE, MAP_PRIVATE |
-+ MAP_NOSYNC | MAP_FIXED, pfd, 0);
-+ }
-+ if (ret == MAP_FAILED)
-+ ret = NULL;
-+#endif
-+ }
- return (ret);
- }
- #endif
---
-1.7.7.4
-
diff --git a/testing/xulrunner/0004-xulrunner-malloc_usable_size.patch b/testing/xulrunner/0004-xulrunner-malloc_usable_size.patch
deleted file mode 100644
index 986b183ec..000000000
--- a/testing/xulrunner/0004-xulrunner-malloc_usable_size.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Timo Teräs <timo.teras@iki.fi>
-
-malloc_usable_size is not defined on uclibc, so workaround
-that in jemalloc. Fix mozalloc linking.
-
---- mozilla-release-old/memory/jemalloc/jemalloc.h
-+++ mozilla-release/memory/jemalloc/jemalloc.h
-@@ -75,8 +75,12 @@
- /* Linux has memalign and malloc_usable_size */
- #if !defined(MOZ_MEMORY_LINUX)
- void *memalign(size_t alignment, size_t size);
--size_t malloc_usable_size(const void *ptr);
- #endif /* MOZ_MEMORY_LINUX */
-+
-+#include <features.h>
-+#if defined(__UCLIBC__) || !defined(MOZ_MEMORY_LINUX)
-+size_t malloc_usable_size(const void *ptr);
-+#endif
-
- void jemalloc_stats(jemalloc_stats_t *stats);
-
---- mozilla-release-old/memory/mozalloc/Makefile.in
-+++ mozilla-release/memory/mozalloc/Makefile.in
-@@ -43,6 +43,10 @@
-
- include $(DEPTH)/config/autoconf.mk
-
-+ifdef MOZ_MEMORY
-+SHARED_LIBRARY_LIBS = $(call EXPAND_LIBNAME_PATH,jemalloc,../jemalloc)
-+endif
-+
- VISIBILITY_FLAGS=
- STL_FLAGS =
- ifdef _MSC_VER
diff --git a/testing/xulrunner/APKBUILD b/testing/xulrunner/APKBUILD
deleted file mode 100644
index e5954846f..000000000
--- a/testing/xulrunner/APKBUILD
+++ /dev/null
@@ -1,112 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
-pkgname=xulrunner
-pkgver=10.0
-_ffoxver=10.0
-pkgrel=4
-pkgdesc="runtime environment for xul-based applications"
-url="http://developer.mozilla.org/en/XULRunner"
-arch="all"
-license="GPL LGPL MPL"
-depends=
-depends_dev="nspr-dev
- nss-dev
- gtk+-dev
- dbus-glib-dev
- alsa-lib-dev
- libvorbis-dev
- libogg-dev
- libtheora-dev
- wireless-tools-dev
- libnotify-dev
- libevent-dev
- libxt-dev
- jpeg-dev
- bzip2-dev
- hunspell-dev
- startup-notification-dev
- sqlite-dev
- libidl-dev
- mesa-dev"
-makedepends="$depends_dev
-
- autoconf2.13
-
- python
- zip
- yasm
-
- autoconf
- automake
- libtool"
-install=""
-options=""
-subpackages="$pkgname-dev"
-# http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/${pkgver}/source/${pkgname}-${pkgver}.source.tar.bz2
-source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}.source.tar.bz2
-
- mozconfig
- 0002-Use-C99-math-isfinite.patch
- 0003-xulrunner-jemalloc-aslr.patch
- 0004-xulrunner-malloc_usable_size.patch
- ff9-aslr-fix.patch
- "
-
-_builddir="${srcdir}/mozilla-release"
-prepare() {
- local i
-
- cd "$_builddir"
-
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-
- cp "${srcdir}/mozconfig" .mozconfig
-}
-
-build() {
- cd "$_builddir"
-
- # mozilla's buildsystem is on drugs, so we just kill our CFLAGS and hope
- # for the best. --nenolod
- unset CFLAGS
- unset CXXFLAGS
-
- make -j1 -f client.mk build \
- MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
-}
-
-package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" -f client.mk install || return 1
-
- # make install does not install xpt.py but its needed by firefox
- mkdir -p "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin
- cp xpcom/typelib/xpt/tools/xpt.py \
- "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin/
-
- msg "Setting up compatibility symlinks..."
- ln -sf /usr/lib/xulrunner-${pkgver}/libxul.so "${pkgdir}"/usr/lib/libxul.so
- ln -sf /usr/lib/xulrunner-${pkgver}/libxpcom.so "${pkgdir}"/usr/lib/libxpcom.so
- ln -sf /usr/lib/xulrunner-${pkgver}/libmozalloc.so "${pkgdir}"/usr/lib/libmozalloc.so
-}
-
-dev() {
- replaces="xulrunner"
- depends="xulrunner"
-
- mkdir -p "${subpkgdir}"/usr/lib
- mv "${pkgdir}"/usr/lib/xulrunner-devel-${pkgver} "${subpkgdir}"/usr/lib
- mv "${pkgdir}"/usr/lib/pkgconfig "${subpkgdir}"/usr/lib
- mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
-}
-
-md5sums="13c61203ccfa583e5a54b4dc22f41233 firefox-10.0.source.tar.bz2
-b0f7d491bc800b69ec718667a4b08acb mozconfig
-1867db217d10722675c88b655db8c2d7 0002-Use-C99-math-isfinite.patch
-7faa279d64c9ec2e7abc7c0497c7e07e 0003-xulrunner-jemalloc-aslr.patch
-d12e0636e1f9877ef2d1df45d5834c87 0004-xulrunner-malloc_usable_size.patch
-96b40acd003a0a586e408bf09ae5af1d ff9-aslr-fix.patch"
diff --git a/testing/xulrunner/ff9-aslr-fix.patch b/testing/xulrunner/ff9-aslr-fix.patch
deleted file mode 100644
index 4e4297d0e..000000000
--- a/testing/xulrunner/ff9-aslr-fix.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- ./js/src/jsgcchunk.cpp 2011-12-22 17:13:21.000000000 +0000
-+++ ./js/src/jsgcchunk.cpp 2011-12-22 17:18:31.000000000 +0000
-@@ -213,7 +213,7 @@
- #elif defined(XP_UNIX)
-
- /* Required on Solaris 10. Might improve performance elsewhere. */
--# if defined(SOLARIS) && defined(MAP_ALIGN)
-+# if (defined(SOLARIS) && defined(MAP_ALIGN)) || defined(MOZ_MEMORY_LINUX)
- # define JS_GC_HAS_MAP_ALIGN
-
- static void *
---- ./js/src/jsgcchunk.cpp 2011-12-22 17:55:24.000000000 +0000
-+++ ./js/src/jsgcchunk.cpp 2011-12-22 18:02:24.000000000 +0000
-@@ -226,12 +226,24 @@
- #ifdef SOLARIS
- void *p = mmap((caddr_t) alignment, size, PROT_READ | PROT_WRITE,
- MAP_PRIVATE | MAP_NOSYNC | MAP_ALIGN | MAP_ANON, -1, 0);
-+ if (p == MAP_FAILED)
-+ return NULL;
- #else
-- void *p = mmap((void *) alignment, size, PROT_READ | PROT_WRITE,
-- MAP_PRIVATE | MAP_NOSYNC | MAP_ALIGN | MAP_ANON, -1, 0);
--#endif
-+ void *p = mmap(NULL, size + alignment, PROT_READ | PROT_WRITE,
-+ MAP_PRIVATE | MAP_NOSYNC | MAP_ANON, -1, 0);
- if (p == MAP_FAILED)
- return NULL;
-+ uintptr_t aligned_ret;
-+ size_t extra_size;
-+
-+ aligned_ret = (uintptr_t)p + alignment - 1;
-+ aligned_ret &= ~(alignment - 1);
-+ extra_size = aligned_ret - (uintptr_t)p;
-+ munmap(p, extra_size);
-+ munmap(p + extra_size + size, alignment - extra_size);
-+ p = (void *)aligned_ret;
-+#endif
-+
- return p;
- }
diff --git a/testing/xulrunner/mozconfig b/testing/xulrunner/mozconfig
deleted file mode 100644
index 2cbb45b7a..000000000
--- a/testing/xulrunner/mozconfig
+++ /dev/null
@@ -1,38 +0,0 @@
-. $topsrcdir/xulrunner/config/mozconfig
-
-ac_add_options --prefix=/usr
-ac_add_options --libdir=/usr/lib
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
-ac_add_options --with-system-jpeg
-ac_add_options --with-system-zlib
-ac_add_options --with-system-bz2
-ac_add_options --with-system-libevent
-ac_add_options --enable-system-hunspell
-ac_add_options --enable-system-sqlite
-ac_add_options --enable-system-cairo
-ac_add_options --with-pthreads
-ac_add_options --enable-strip
-ac_add_options --disable-tests
-ac_add_options --disable-mochitest
-ac_add_options --disable-installer
-ac_add_options --disable-debug
-ac_add_options --enable-optimize
-ac_add_options --enable-default-toolkit=cairo-gtk2
-ac_add_options --enable-pango
-ac_add_options --enable-svg
-ac_add_options --enable-canvas
-ac_add_options --disable-javaxpcom
-ac_add_options --disable-crashreporter
-ac_add_options --enable-safe-browsing
-ac_add_options --enable-startup-notification
-ac_add_options --enable-extensions=default
-ac_add_options --enable-jemalloc
-ac_add_options --disable-elf-hack
-
-# export LIBS="-lubacktrace"
-export BUILD_OFFICIAL=1
-export MOZILLA_OFFICIAL=1
-
-mk_add_options BUILD_OFFICIAL=1
-mk_add_options MOZILLA_OFFICIAL=1