summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-02-09 19:23:39 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-02-09 19:40:22 -0600
commit19057f79c2bfa546d2badfcab7bd036b96b6db64 (patch)
tree9e7be195e5939a7851820c22caae9e083a172e03 /testing
parent5017a62317c4020cb555c31bf3f4e53b385b8041 (diff)
downloadaports-19057f79c2bfa546d2badfcab7bd036b96b6db64.tar.bz2
aports-19057f79c2bfa546d2badfcab7bd036b96b6db64.tar.xz
main/rtpproxy: moved from testing
moved rtpproxy to main
Diffstat (limited to 'testing')
-rw-r--r--testing/rtpproxy/APKBUILD48
-rw-r--r--testing/rtpproxy/rtpproxy.confd8
-rw-r--r--testing/rtpproxy/rtpproxy.initd25
-rw-r--r--testing/rtpproxy/rtpproxy.pre-install5
4 files changed, 0 insertions, 86 deletions
diff --git a/testing/rtpproxy/APKBUILD b/testing/rtpproxy/APKBUILD
deleted file mode 100644
index 30629c0a5..000000000
--- a/testing/rtpproxy/APKBUILD
+++ /dev/null
@@ -1,48 +0,0 @@
-# Contributor: Jeff Bilyk <jbilyk@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=rtpproxy
-pkgver=1.2.1
-pkgrel=1
-pkgdesc="RTP proxy"
-url="http://www.rtpproxy.org"
-arch="all"
-license="BSD"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install="$pkgname.pre-install"
-subpackages="$pkgname-doc"
-source="http://b2bua.org/chrome/site/$pkgname-$pkgver.tar.gz
- rtpproxy.confd
- rtpproxy.initd"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="b0b5d6cdce3f17cdbbac473c11a2d0e5 rtpproxy-1.2.1.tar.gz
-aee99ab9f380cd0b43754ae658f26c92 rtpproxy.confd
-b0f8894794b3f24af21ed050477851b1 rtpproxy.initd"
diff --git a/testing/rtpproxy/rtpproxy.confd b/testing/rtpproxy/rtpproxy.confd
deleted file mode 100644
index cb53e6d7c..000000000
--- a/testing/rtpproxy/rtpproxy.confd
+++ /dev/null
@@ -1,8 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-# Additional options to start rtpproxy with
-#
-# see "rtpproxy -h" for a list of options
-RTPPROXY_OPTS=""
diff --git a/testing/rtpproxy/rtpproxy.initd b/testing/rtpproxy/rtpproxy.initd
deleted file mode 100644
index 5e53e51e8..000000000
--- a/testing/rtpproxy/rtpproxy.initd
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header$
-
-PIDFILE=/var/run/rtpproxy.pid
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting rtpproxy"
- start-stop-daemon --start --quiet --pidfile "${PIDFILE}" \
- --exec /usr/bin/rtpproxy \
- -- -urtpproxy:rtpproxy -p"${PIDFILE}" ${RTPPROXY_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping rtpproxy"
- start-stop-daemon --stop --quiet --pidfile "${PIDFILE}"
- eend $?
-}
-
diff --git a/testing/rtpproxy/rtpproxy.pre-install b/testing/rtpproxy/rtpproxy.pre-install
deleted file mode 100644
index 498bedbd0..000000000
--- a/testing/rtpproxy/rtpproxy.pre-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-addgroup -S rtpproxy 2>/dev/null
-adduser -S -G rtpproxy -H -h /usr/share/rtpproxy -s /bin/false rtpproxy 2>/dev/null
-exit 0