summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2014-05-01 12:36:00 +0300
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2014-05-01 12:40:10 +0300
commit81157a4c9f7955f32f3fbcf7b6fdd8470c3d975f (patch)
tree2ab58903529d845f4fb77308bb28ea418c1b946f /testing
parentf98161dc2bf1f6cc312620f7060ac558fed79a6b (diff)
downloadaports-81157a4c9f7955f32f3fbcf7b6fdd8470c3d975f.tar.bz2
aports-81157a4c9f7955f32f3fbcf7b6fdd8470c3d975f.tar.xz
py-django-oscar: new package
dependencies included
Diffstat (limited to 'testing')
-rw-r--r--testing/py-babel/APKBUILD37
-rw-r--r--testing/py-django-appconf/APKBUILD37
-rw-r--r--testing/py-django-compressor/APKBUILD37
-rw-r--r--testing/py-django-extra-views/APKBUILD37
-rw-r--r--testing/py-django-haystack/APKBUILD37
-rw-r--r--testing/py-django-oscar/APKBUILD40
-rw-r--r--testing/py-django-sorl-thumbnail/APKBUILD37
-rw-r--r--testing/py-django-south/APKBUILD37
-rw-r--r--testing/py-django-treebeard/APKBUILD37
-rw-r--r--testing/py-phonenumbers/APKBUILD36
10 files changed, 372 insertions, 0 deletions
diff --git a/testing/py-babel/APKBUILD b/testing/py-babel/APKBUILD
new file mode 100644
index 000000000..1f3118403
--- /dev/null
+++ b/testing/py-babel/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-babel
+pkgver=1.3
+pkgrel=0
+pkgdesc="Python i18n tool"
+url=http://babel.pocoo.org/
+arch=noarch
+license=BSD
+depends=py-tz
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/B/Babel/Babel-$pkgver.tar.gz
+
+_builddir=$srcdir/Babel-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="5264ceb02717843cbc9ffce8e6e06bdb Babel-1.3.tar.gz"
+sha256sums="9f02d0357184de1f093c10012b52e7454a1008be6a5c185ab7a3307aceb1d12e Babel-1.3.tar.gz"
+sha512sums="3173d578c36d7a20d14ffcf6406ec9fe301e71a199069b3d2e53bd0c66e7f83d6e94f071dc08f2708202ec1ace4d14f4476234cc8347a37b05317302f0cfe0cf Babel-1.3.tar.gz"
diff --git a/testing/py-django-appconf/APKBUILD b/testing/py-django-appconf/APKBUILD
new file mode 100644
index 000000000..49e794ab9
--- /dev/null
+++ b/testing/py-django-appconf/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-django-appconf
+pkgver=0.6
+pkgrel=0
+pkgdesc="Packaged application configuation helper for Django"
+url=http://django-appconf.readthedocs.org/
+arch=noarch
+license=BSD
+depends="py-django py-six"
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/d/django-appconf/django-appconf-$pkgver.tar.gz
+
+_builddir=$srcdir/django-appconf-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="40494042c3c8bd1e054c884e5ed4bb6c django-appconf-0.6.tar.gz"
+sha256sums="a88ed8fb923a53c70c2c46fbe4508b5f81646b4b01401f1568a821671b33215c django-appconf-0.6.tar.gz"
+sha512sums="b6c882ef7d2088e4a17c5099bd9581fec7c5185c13b1d3aa1f46daf33d8f51b047da9dc4091822ab7523e2eba9922fe1ec6b681b544b1657c43879e591278913 django-appconf-0.6.tar.gz"
diff --git a/testing/py-django-compressor/APKBUILD b/testing/py-django-compressor/APKBUILD
new file mode 100644
index 000000000..7f72dc031
--- /dev/null
+++ b/testing/py-django-compressor/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-django-compressor
+pkgver=1.3
+pkgrel=0
+pkgdesc="JavaScript and CSS compressor for Django"
+url=https://github.com/django-compressor/django-compressor
+arch=noarch
+license="MIT and ASL 2.0 and BSD"
+depends="py-django py-django-appconf"
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/d/django_compressor/django_compressor-$pkgver.tar.gz
+
+_builddir=$srcdir/django_compressor-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="da8ee3c5908d648ded03dfe996499b15 django_compressor-1.3.tar.gz"
+sha256sums="66ff1a845a6c1b16c4cf552ee3d746033979e46cd9bd5d999d4b5dae93327a52 django_compressor-1.3.tar.gz"
+sha512sums="73d7ed68c9050945968324eb061e8bf605c3758d4df924c8e12b326cd823b1ec92aef7b984fd282cb491ef3025a3ae5733f03063036361fdd0f1e0a23e875ea2 django_compressor-1.3.tar.gz"
diff --git a/testing/py-django-extra-views/APKBUILD b/testing/py-django-extra-views/APKBUILD
new file mode 100644
index 000000000..87a012075
--- /dev/null
+++ b/testing/py-django-extra-views/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-django-extra-views
+pkgver=0.6.4
+pkgrel=0
+pkgdesc="Extra class-based views for Django"
+url=https://github.com/AndrewIngram/django-extra-views
+arch=noarch
+license=MIT
+depends=py-django
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/d/django-extra-views/django-extra-views-$pkgver.tar.gz
+
+_builddir=$srcdir/django-extra-views-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="45c97d2d3e9cd4a2a3e75db23dd14c98 django-extra-views-0.6.4.tar.gz"
+sha256sums="b34764361f71ad2758cda13baae292bf0f5b1f2daf28353f916c457a98484aa5 django-extra-views-0.6.4.tar.gz"
+sha512sums="09789f4d999f671cda2d5893239c645e74d291c3fc5a07887a87fbaee09fa3821413d14b3c8b431e4c607581ba2f6328926ee39806158aee0145a0ce9ee23b0a django-extra-views-0.6.4.tar.gz"
diff --git a/testing/py-django-haystack/APKBUILD b/testing/py-django-haystack/APKBUILD
new file mode 100644
index 000000000..319fdb94b
--- /dev/null
+++ b/testing/py-django-haystack/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-django-haystack
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Modular search for Django"
+url=http://haystacksearch.org/
+arch=noarch
+license=BSD
+depends=py-django
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/d/django-haystack/django-haystack-$pkgver.tar.gz
+
+_builddir=$srcdir/django-haystack-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="0bc74c0d71c30169ddb796c20655fe98 django-haystack-2.1.0.tar.gz"
+sha256sums="b8b9aa47cbb1a845ac5ef44d3ce02fcaf148f453c76f93d987b95a78d3698230 django-haystack-2.1.0.tar.gz"
+sha512sums="2241ebcea9d42733af486f80508d3ba47231f5881e60156dfedb9e7a604ee8ff59fe97213c007d684484f9eb21f182dd9c9106fc35e03510070e529a1bb5ce3f django-haystack-2.1.0.tar.gz"
diff --git a/testing/py-django-oscar/APKBUILD b/testing/py-django-oscar/APKBUILD
new file mode 100644
index 000000000..6e3483871
--- /dev/null
+++ b/testing/py-django-oscar/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-django-oscar
+pkgver=0.7
+pkgrel=0
+pkgdesc="Domain-driven e-commerce for Django"
+url=http://oscarcommerce.com/
+arch=noarch
+license=BSD
+depends="py-babel py-django py-django-compressor py-django-extra-views
+ py-django-haystack py-django-sorl-thumbnail py-django-south
+ py-django-treebeard py-phonenumbers py-pillow py-purl py-six
+ py-unidecode"
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/d/django-oscar/django-oscar-$pkgver.tar.gz
+
+_builddir=$srcdir/django-oscar-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ ./setup.py install --root "$pkgdir"
+}
+
+md5sums="a518e4fcd92cadd84f43e49fc8c15f2f django-oscar-0.7.tar.gz"
+sha256sums="fa33416e2cf03d94213f81ad2d17d930eb2b2eb574dbb71f1f655d049d230f55 django-oscar-0.7.tar.gz"
+sha512sums="49e7709f18e56fd1c307387135dded27f227d9d9e167c72cea5eb5eed47c99b5fe49364592bd66ad1b3739906f27fb02c846466574a71f37a3cd6cffdc232290 django-oscar-0.7.tar.gz"
diff --git a/testing/py-django-sorl-thumbnail/APKBUILD b/testing/py-django-sorl-thumbnail/APKBUILD
new file mode 100644
index 000000000..64ebc8f47
--- /dev/null
+++ b/testing/py-django-sorl-thumbnail/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-django-sorl-thumbnail
+pkgver=11.12.1b
+pkgrel=0
+pkgdesc="Thumbnails for Django"
+url=https://github.com/mariocesar/sorl-thumbnail
+arch=noarch
+license=BSD
+depends="py-django py-pillow"
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/s/sorl-thumbnail/sorl-thumbnail-$pkgver.tar.gz
+
+_builddir=$srcdir/sorl-thumbnail-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="3e1392b79f7e4b6dc4046f5efc00297f sorl-thumbnail-11.12.1b.tar.gz"
+sha256sums="6b309388f4c4fbbeec6813ccb3c321ba3245ef2b7de044ed7b26853ec75c05f3 sorl-thumbnail-11.12.1b.tar.gz"
+sha512sums="6907ac0034139b6b30614238322916a002c6eaf9ff3e8d5bc6dd4e0c1e9ecbee95b9e7bc8fc12af97f04c1af035db974e24083acd3110f8a4f7f2f2e3d877e95 sorl-thumbnail-11.12.1b.tar.gz"
diff --git a/testing/py-django-south/APKBUILD b/testing/py-django-south/APKBUILD
new file mode 100644
index 000000000..324c0f8eb
--- /dev/null
+++ b/testing/py-django-south/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-django-south
+pkgver=0.8.4
+pkgrel=0
+pkgdesc="Migrations for Django"
+url=http://south.aeracode.org/
+arch=noarch
+license=BSD
+depends=py-django
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/S/South/South-$pkgver.tar.gz
+
+_builddir=$srcdir/South-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ ./setup.py install --root "$pkgdir"
+}
+
+md5sums="ccd6ebadd3e2c8c6ef16d771632f7840 South-0.8.4.tar.gz"
+sha256sums="5cf6bdc2967be8dd7845d3058e3af0a73408e5383c9effc3123bb48c3cc5c821 South-0.8.4.tar.gz"
+sha512sums="5d01605aac6feffb9423137f1db7cf599e0bb6417e8fa3735e1c5c9fdf6c22bd0658d4daac92d4a04594632a5e68750916331200fbd76f0d1fb3e47bb5e91adb South-0.8.4.tar.gz"
diff --git a/testing/py-django-treebeard/APKBUILD b/testing/py-django-treebeard/APKBUILD
new file mode 100644
index 000000000..9121d28b4
--- /dev/null
+++ b/testing/py-django-treebeard/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-django-treebeard
+pkgver=2.0
+pkgrel=0
+pkgdesc="Efficient tree implementations for Django"
+url=https://tabo.pe/projects/django-treebeard/
+arch=noarch
+license="ASL 2.0"
+depends=py-django
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/d/django-treebeard/django-treebeard-$pkgver.tar.gz
+
+_builddir=$srcdir/django-treebeard-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="18801f6079c60a0dc9c79a589c72a763 django-treebeard-2.0.tar.gz"
+sha256sums="64fa9e8a4edc7a9b4336b81738790dfdfbef0a5c47cab26b13fc95f75bcd7b44 django-treebeard-2.0.tar.gz"
+sha512sums="686e7a89b805850ca0cda569273ea96f158ef29b8a23019a95afc70c4fb51c5758ed9d13bb44a28dc5e0ed419dac400211265ee8764b9fbfc59db39ae0e4833c django-treebeard-2.0.tar.gz"
diff --git a/testing/py-phonenumbers/APKBUILD b/testing/py-phonenumbers/APKBUILD
new file mode 100644
index 000000000..1fb0d0054
--- /dev/null
+++ b/testing/py-phonenumbers/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-phonenumbers
+pkgver=6.0.0a
+pkgrel=0
+pkgdesc="International phone number library for Python"
+url=https://github.com/daviddrysdale/python-phonenumbers
+arch=noarch
+license="ASL 2.0"
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/p/phonenumbers/phonenumbers-$pkgver.tar.gz
+
+_builddir=$srcdir/phonenumbers-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ ./setup.py install --root "$pkgdir"
+}
+
+md5sums="f0c91fe551c92ded82953b786bbf0c32 phonenumbers-6.0.0a.tar.gz"
+sha256sums="bbc3256ccaa417c6b0262ba57d86245b7fc8227b4fe71d9d245268f02c7dab2d phonenumbers-6.0.0a.tar.gz"
+sha512sums="5a56824978f2fb15c543aad380fa342d1149c1f3d316868d2550ad970033653fb4749a0544b4110ca72d7c89ae41ffd7622856db6aad34eb4548e736ebfabd9c phonenumbers-6.0.0a.tar.gz"