summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-05-07 09:44:55 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-05-07 09:45:35 +0300
commit9893cf0f44ca86d40f46e3b0b4306b42bb5041ac (patch)
tree55b3063b4062844cae66dadcb8d79b38ce3f425f /testing
parentb8cb931e312b5590897c310b0e3bc3f90d6ef809 (diff)
downloadaports-9893cf0f44ca86d40f46e3b0b4306b42bb5041ac.tar.bz2
aports-9893cf0f44ca86d40f46e3b0b4306b42bb5041ac.tar.xz
main/nginx-lua: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/nginx-lua/APKBUILD105
-rw-r--r--testing/nginx-lua/ipv6.patch42
-rw-r--r--testing/nginx-lua/musl-crypt-fix.patch13
-rw-r--r--testing/nginx-lua/nginx-lua.pre-install9
l---------testing/nginx-lua/nginx-lua.pre-upgrade1
-rwxr-xr-xtesting/nginx-lua/nginx.initd42
-rw-r--r--testing/nginx-lua/nginx.logrotate12
7 files changed, 0 insertions, 224 deletions
diff --git a/testing/nginx-lua/APKBUILD b/testing/nginx-lua/APKBUILD
deleted file mode 100644
index 0000e9c0a..000000000
--- a/testing/nginx-lua/APKBUILD
+++ /dev/null
@@ -1,105 +0,0 @@
-# Maintainer: Cameron Banta <cbanta@gmail.com>
-# Contributor: Jeff Bilyk <jbilyk@gmail.com>
-# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
-# Contributor: Timo Teräs <timo.teras@iki.fi>
-
-pkgname=nginx-lua
-_pkgname=nginx
-pkgver=1.6.0
-_ngx_devel_kit_ver=0.2.19
-_ngx_lua_ver=0.9.7
-pkgrel=0
-pkgdesc="lightweight HTTP and reverse proxy server with Lua support"
-url="http://www.nginx.org"
-arch="all"
-license="Custom"
-install="$pkgname.pre-install $pkgname.pre-upgrade"
-depends="!nginx"
-makedepends="pcre-dev openssl-dev zlib-dev luajit-dev paxctl"
-source="http://nginx.org/download/$_pkgname-$pkgver.tar.gz
- nginx-devel-kit-$_ngx_devel_kit_ver.tar.gz::https://github.com/simpl/ngx_devel_kit/archive/v$_ngx_devel_kit_ver.tar.gz
- lua-nginx-module-$_ngx_lua_ver.tar.gz::https://github.com/chaoslawful/lua-nginx-module/archive/v$_ngx_lua_ver.tar.gz
-
- musl-crypt-fix.patch
- ipv6.patch
-
- nginx.initd
- nginx.logrotate
- "
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-
-build() {
- cd "$_builddir"
- LUAJIT_INC="/usr/include/luajit-2.0" \
- LUAJIT_LIB="/usr/lib" \
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/$_pkgname/$_pkgname.conf \
- --pid-path=/var/run/$_pkgname.pid \
- --lock-path=/var/run/$_pkgname.lock \
- --error-log-path=/var/log/$_pkgname/error.log \
- --http-log-path=/var/log/$_pkgname/access.log \
- --http-client-body-temp-path=/tmp/$_pkgname/client-body \
- --http-proxy-temp-path=/tmp/$_pkgname/proxy \
- --http-fastcgi-temp-path=/tmp/$_pkgname/fastcgi \
- --user=nginx \
- --group=nginx \
- --with-ipv6 \
- --with-pcre-jit \
- --with-http_ssl_module \
- --with-http_gzip_static_module \
- --with-http_spdy_module \
- --with-mail \
- --with-mail_ssl_module \
- --add-module="$srcdir/ngx_devel_kit-$_ngx_devel_kit_ver" \
- --add-module="$srcdir/lua-nginx-module-$_ngx_lua_ver" \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
-
- local paxflags="-m"
- [ "$CARCH" = "x86" ] && paxflags="-msp"
- paxctl -c $paxflags "$pkgdir"/usr/sbin/nginx || return 1
-
- install -m755 -D "$srcdir"/$_pkgname.initd "$pkgdir"/etc/init.d/$_pkgname
- install -m644 -D "$srcdir"/$_pkgname.logrotate "$pkgdir"/etc/logrotate.d/$_pkgname
-
- install -m644 -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}
-
-md5sums="8efa354f1c3c2ccf434a50d3fbe82340 nginx-1.6.0.tar.gz
-09a18178adca7b5674129d8100ce4f68 nginx-devel-kit-0.2.19.tar.gz
-c6cd8cf0fd36fbb6a3e74791040333f7 lua-nginx-module-0.9.7.tar.gz
-3aeb488921109e60d02ed64d36790aeb musl-crypt-fix.patch
-801a87f7f9d27f8ad85b41a78b4c4461 ipv6.patch
-a00403a764478f5459d850bb387ca19b nginx.initd
-8823274a834332d3db4f62bf7dd1fb7d nginx.logrotate"
-sha256sums="943ad757a1c3e8b3df2d5c4ddacc508861922e36fa10ea6f8e3a348fc9abfc1a nginx-1.6.0.tar.gz
-501f299abdb81b992a980bda182e5de5a4b2b3e275fbf72ee34dd7ae84c4b679 nginx-devel-kit-0.2.19.tar.gz
-c2a3a3240dd55274b00f7efc8f35598d77861663f01a720a28a52131b824b691 lua-nginx-module-0.9.7.tar.gz
-8c398640bd379c1c6a2fafcd2b3848a72902e47924e8e2490b312c141eec5d70 musl-crypt-fix.patch
-a24ef5843ae0afa538b00c37eb7da7870f9d7f146f52a9668678f7296cf71d9b ipv6.patch
-67df748bd7ef4f3c3b5eef9dd7e3b352ef671dd7cfb9db56e096eed77a442d67 nginx.initd
-cea0c6f8de55a4c3a3eccc57910de1c3116634082c8e5b660630fb927a29f38d nginx.logrotate"
-sha512sums="715b3aa6012e2e29f3b4e6affff4641de0958faa25c0acedb8091b0f4c8506a8912a7e507bcb1f89fc5fe0a1233ab7770dc6ed742698874f43af72b7d08e48f7 nginx-1.6.0.tar.gz
-915954acf16a27fbd3c93c154012d38e864f1d8dfd51cde401bba26e46eb3e3c778ec4c92f4f8ed83ac001e96cee72765554d0e4da06acf6a4be5184b23b3657 nginx-devel-kit-0.2.19.tar.gz
-cd4718d7e8a8bf260d18d6d5aa10d8a07072fea3e6efc04d6775f20681080937fb093dc555e9b9a1560074a19522a099a391149057c365c4cda20532c6219c56 lua-nginx-module-0.9.7.tar.gz
-21114c775e4bdd1f7b8b9abc143284945e96ed1d8c49904ddf918abad87b16253f918ba47976cd2df32f0fdb8a7dad399d4200e879db2da6cf93a28aab236a75 musl-crypt-fix.patch
-68d64a84568ec2df0366925ab282a05ebe21a85044b6c7844a47573cfd8cc8ed119cc772358bc3fff36e2d4fdf583a730592825f5f98632993ca86d1f8438d5f ipv6.patch
-9c6b357c460998187d7a26c0f3c8abc69c91b523a6f340c1f6ed3c863101a39eeb61e92b4cfec6a04af2b495c354c33f232ce5e59ed29edd6855e430ca73d168 nginx.initd
-01b77cff16f6e8bfd7fa1d4d20f625bbcddd08f0509173452d060c342c93dc315a7b0560f4734323a5d29ea294de0491f2e3f32e5337574e1a28ebc005eceea8 nginx.logrotate"
diff --git a/testing/nginx-lua/ipv6.patch b/testing/nginx-lua/ipv6.patch
deleted file mode 100644
index 9b05f8ff8..000000000
--- a/testing/nginx-lua/ipv6.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/src/http/ngx_http_core_module.c
-+++ b/src/http/ngx_http_core_module.c
-@@ -2442,7 +2442,11 @@
- ngx_uint_t i;
- ngx_conf_t pcf;
- ngx_http_module_t *module;
-+#if (NGX_HAVE_INET6)
-+ struct sockaddr_in6 *sin6;
-+#else
- struct sockaddr_in *sin;
-+#endif
- ngx_http_conf_ctx_t *ctx, *http_ctx;
- ngx_http_listen_opt_t lsopt;
- ngx_http_core_srv_conf_t *cscf, **cscfp;
-@@ -2526,6 +2530,19 @@
- if (rv == NGX_CONF_OK && !cscf->listen) {
- ngx_memzero(&lsopt, sizeof(ngx_http_listen_opt_t));
-
-+#if (NGX_HAVE_INET6)
-+ sin6 = &lsopt.u.sockaddr_in6;
-+
-+ sin6->sin6_family = AF_INET6;
-+#if (NGX_WIN32)
-+ sin6->sin6_port = htons(80);
-+#else
-+ sin6->sin6_port = htons((getuid() == 0) ? 80 : 8000);
-+#endif
-+ sin6->sin6_addr = in6addr_any;
-+
-+ lsopt.socklen = sizeof(struct sockaddr_in6);
-+#else
- sin = &lsopt.u.sockaddr_in;
-
- sin->sin_family = AF_INET;
-@@ -2537,6 +2554,7 @@
- sin->sin_addr.s_addr = INADDR_ANY;
-
- lsopt.socklen = sizeof(struct sockaddr_in);
-+#endif
-
- lsopt.backlog = NGX_LISTEN_BACKLOG;
- lsopt.rcvbuf = -1;
diff --git a/testing/nginx-lua/musl-crypt-fix.patch b/testing/nginx-lua/musl-crypt-fix.patch
deleted file mode 100644
index 2f11fe2e9..000000000
--- a/testing/nginx-lua/musl-crypt-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- nginx-1.4.4/src/os/unix/ngx_user.c.orig
-+++ nginx-1.4.4/src/os/unix/ngx_user.c
-@@ -31,8 +31,10 @@
- struct crypt_data cd;
-
- cd.initialized = 0;
-+#ifdef __GLIBC__
- /* work around the glibc bug */
- cd.current_salt[0] = ~salt[0];
-+#endif
-
- value = crypt_r((char *) key, (char *) salt, &cd);
-
diff --git a/testing/nginx-lua/nginx-lua.pre-install b/testing/nginx-lua/nginx-lua.pre-install
deleted file mode 100644
index 55b5bfcda..000000000
--- a/testing/nginx-lua/nginx-lua.pre-install
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-addgroup -g 82 -S www-data 2>/dev/null
-addgroup -S nginx 2>/dev/null
-adduser -S -G nginx -H -h /var/www/localhost/htdocs -s /sbin/nologin \
- -D nginx 2>/dev/null
-addgroup nginx www-data 2>/dev/null
-
-exit 0
diff --git a/testing/nginx-lua/nginx-lua.pre-upgrade b/testing/nginx-lua/nginx-lua.pre-upgrade
deleted file mode 120000
index d4a5f981c..000000000
--- a/testing/nginx-lua/nginx-lua.pre-upgrade
+++ /dev/null
@@ -1 +0,0 @@
-nginx-lua.pre-install \ No newline at end of file
diff --git a/testing/nginx-lua/nginx.initd b/testing/nginx-lua/nginx.initd
deleted file mode 100755
index ce2b7b8bb..000000000
--- a/testing/nginx-lua/nginx.initd
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/sbin/runscript
-
-extra_started_commands="reload"
-extra_commands="configtest"
-
-depend() {
- need net
- use dns logger netmount
-}
-
-CONFFILE=${CONFFILE:-/etc/nginx/${SVCNAME}.conf}
-PIDFILE=${PIDFILE:-/var/run/${SVCNAME}.pid}
-
-configtest() {
- ebegin "Checking ${SVCNAME} configuration"
- mkdir -p /tmp/nginx
- /usr/sbin/nginx -c ${CONFFILE} -t
- eend $? "failed, please correct errors above"
-}
-
-start() {
- configtest || return 1
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --pidfile "${PIDFILE}" \
- --exec /usr/sbin/nginx -- -c ${CONFFILE} -g "pid ${PIDFILE};"
- eend $? "Failed to start ${SVCNAME}"
-}
-
-stop() {
- configtest || return 1
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --pidfile "${PIDFILE}"
- eend $? "Failed to stop ${SVCNAME}"
- rm -f "${PIDFILE}"
-}
-
-reload() {
- configtest || return 1
- ebegin "Refreshing ${SVCNAME} configuration"
- kill -HUP $(cat "${PIDFILE}") &>/dev/null
- eend $? "Failed to reload nginx"
-}
diff --git a/testing/nginx-lua/nginx.logrotate b/testing/nginx-lua/nginx.logrotate
deleted file mode 100644
index 7778b1108..000000000
--- a/testing/nginx-lua/nginx.logrotate
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/files/nginx.logrotate,v 1.1 2010/01/03 20:29:40 djc Exp $
-
-/var/log/nginx/*.log {
- missingok
- sharedscripts
- postrotate
- kill -USR1 `cat /var/run/nginx.pid`
- endscript
-}
-