summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-04-09 08:25:09 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-04-09 08:25:33 -0500
commit0381828da41f0c2d524f4bd2fed525b14c35c2d7 (patch)
tree7852e70772f460a8dfaa1afe9260a05dd4ef6b82 /testing
parent7c36be22a3475208e976eb31f382aa9004b31c13 (diff)
downloadaports-0381828da41f0c2d524f4bd2fed525b14c35c2d7.tar.bz2
aports-0381828da41f0c2d524f4bd2fed525b14c35c2d7.tar.xz
main/bsnes: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/bsnes/APKBUILD45
-rw-r--r--testing/bsnes/nall-strlcpy.patch31
-rw-r--r--testing/bsnes/no-pulseaudio.patch11
3 files changed, 0 insertions, 87 deletions
diff --git a/testing/bsnes/APKBUILD b/testing/bsnes/APKBUILD
deleted file mode 100644
index 49be44f5e..000000000
--- a/testing/bsnes/APKBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
-pkgname=bsnes
-pkgver=0.77
-_x=${pkgver%.*}
-_y=${pkgver#*.}
-_pkgver="v${_x}${_y}"
-pkgrel=1
-pkgdesc="high accuracy SNES emulator"
-url="http://byuu.org/bsnes/"
-arch="all"
-license="GPL"
-depends=
-depends_dev="qt-dev openal-soft-dev sdl-dev alsa-lib-dev mesa-dev libao-dev libxv-dev"
-makedepends="$depends_dev"
-install=""
-subpackages=
-source="http://bsnes.googlecode.com/files/${pkgname}_${_pkgver}-source.tar.bz2
- nall-strlcpy.patch
- no-pulseaudio.patch"
-
-_builddir="${srcdir}/${pkgname}_${_pkgver}-source/bsnes"
-prepare() {
- local i
- cd "$_builddir/.."
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- make compiler=gcc prefix=/usr profile=performance || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" prefix=/usr profile=performance install || return 1
-}
-
-md5sums="77cd5f73733060c0c19dfe0f5a33e0b6 bsnes_v077-source.tar.bz2
-d5017142f2cbccac878bbfc799b3445f nall-strlcpy.patch
-07caea846bf49ee6f5deaf999dffbd5f no-pulseaudio.patch"
diff --git a/testing/bsnes/nall-strlcpy.patch b/testing/bsnes/nall-strlcpy.patch
deleted file mode 100644
index dd4a005a6..000000000
--- a/testing/bsnes/nall-strlcpy.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- bsnes_v077-source/bsnes/snes/system/serialization.cpp
-+++ bsnes_v077-source/bsnes/snes/system/serialization.cpp
-@@ -7,7 +7,7 @@
- char profile[16], description[512];
- memset(&profile, 0, sizeof profile);
- memset(&description, 0, sizeof description);
-- strlcpy(profile, Info::Profile, sizeof profile);
-+ nall::strlcpy(profile, Info::Profile, sizeof profile);
-
- s.integer(signature);
- s.integer(version);
---- bsnes_v077-source/bsnes/ui/tools/state-manager.cpp
-+++ bsnes_v077-source/bsnes/ui/tools/state-manager.cpp
-@@ -130,7 +130,7 @@
- string StateManager::slotLoadDescription(unsigned i) {
- if(slot[i].capacity() == 0) return "(empty)";
- char text[512];
-- strlcpy(text, (const char*)slot[i].data() + HeaderLength, 512);
-+ nall::strlcpy(text, (const char*)slot[i].data() + HeaderLength, 512);
- return text;
- }
-
-@@ -138,7 +138,7 @@
- if(stateList.selected() == false) return;
- string text = descEdit.text();
- if(slot[stateList.selection()].capacity() > 0) {
-- strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, 512);
-+ nall::strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, 512);
- }
- refresh();
- }
diff --git a/testing/bsnes/no-pulseaudio.patch b/testing/bsnes/no-pulseaudio.patch
deleted file mode 100644
index 5a5dea3e1..000000000
--- a/testing/bsnes/no-pulseaudio.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- bsnes_v077-source.orig/bsnes/ui/Makefile
-+++ bsnes_v077-source/bsnes/ui/Makefile
-@@ -14,7 +14,7 @@
- link += `pkg-config --libs QtCore QtGui`
-
- ruby := video.glx video.xv video.sdl
-- ruby += audio.alsa audio.openal audio.oss audio.pulseaudio audio.pulseaudiosimple audio.ao
-+ ruby += audio.alsa audio.openal audio.oss audio.ao
- ruby += input.sdl input.x
-
- link += $(if $(findstring audio.openal,$(ruby)),-lopenal)