summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-09-11 09:57:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-09-11 09:57:58 +0000
commitd59804fa0bd0a7d1ade1c066c76f21ab038bb8f5 (patch)
tree0eac7effab0f703b52eaa5766b77d283e1a8cd70 /testing
parent182f8fa250ea665d5b76116e61a96752108f7265 (diff)
downloadaports-d59804fa0bd0a7d1ade1c066c76f21ab038bb8f5.tar.bz2
aports-d59804fa0bd0a7d1ade1c066c76f21ab038bb8f5.tar.xz
testing/sshpass: new aport
Non-interactive SSH authentication utility http://sshpass.sourceforge.net/ ref #750
Diffstat (limited to 'testing')
-rw-r--r--testing/sshpass/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/sshpass/APKBUILD b/testing/sshpass/APKBUILD
new file mode 100644
index 000000000..c47f23ffc
--- /dev/null
+++ b/testing/sshpass/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sshpass
+pkgver=1.05
+pkgrel=0
+pkgdesc="Non-interactive SSH authentication utility"
+url="http://sshpass.sourceforge.net/"
+arch="all"
+license="GPLv2"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sshpass/sshpass-$pkgver.tar.gz"
+
+_builddir="$srcdir"/sshpass-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="c52d65fdee0712af6f77eb2b60974ac7 sshpass-1.05.tar.gz"