summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-02 08:14:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-02 08:14:49 +0000
commit742ec6824d8aebafacc1f784bcb42adbcc919a57 (patch)
treeedbd41328d3df604b15b0d83a74fdef98381e57f /testing
parentcd07fdba3c14d53958fe9feb2a655561249fe8b2 (diff)
downloadaports-742ec6824d8aebafacc1f784bcb42adbcc919a57.tar.bz2
aports-742ec6824d8aebafacc1f784bcb42adbcc919a57.tar.xz
testing/spice: new aport
Implements the SPICE protocol http://www.spice-space.org/
Diffstat (limited to 'testing')
-rw-r--r--testing/spice/APKBUILD63
-rw-r--r--testing/spice/cstdarg.patch10
2 files changed, 73 insertions, 0 deletions
diff --git a/testing/spice/APKBUILD b/testing/spice/APKBUILD
new file mode 100644
index 000000000..d349182f0
--- /dev/null
+++ b/testing/spice/APKBUILD
@@ -0,0 +1,63 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=spice
+pkgver=0.10.0
+pkgrel=0
+pkgdesc="Implements the SPICE protocol"
+url="http://www.spice-space.org/"
+arch="all"
+license="LGPLv2+"
+depends=""
+makedepends="spice-protocol pixman-dev alsa-lib-dev openssl-dev jpeg-dev
+ libxrandr-dev cyrus-sasl-dev celt051-dev libxfixes-dev python-dev
+ bash cegui06-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-server $pkgname-client"
+source="http://www.spice-space.org/download/releases/spice-$pkgver.tar.bz2
+ cstdarg.patch"
+
+_builddir="$srcdir"/spice-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-gui \
+ || return 1
+ make -C common WARN_CFLAGS='' || return 1
+ make -C client WARN_CFLAGS='' || return 1
+ make WARN_CFLAGS='' || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+server() {
+ pkgdesc="Server library for SPICE"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*server.so.* "$subpkgdir"/usr/lib/
+}
+
+client() {
+ pkgdesc="SPICE client"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/spicec "$subpkgdir"/usr/bin/
+}
+
+md5sums="d9f0b0280c9e2291623c9560e156be26 spice-0.10.0.tar.bz2
+3e61fdc18bf201a2b54b332fdbe2912e cstdarg.patch"
diff --git a/testing/spice/cstdarg.patch b/testing/spice/cstdarg.patch
new file mode 100644
index 000000000..7a16dc579
--- /dev/null
+++ b/testing/spice/cstdarg.patch
@@ -0,0 +1,10 @@
+--- ./client/common.h.orig
++++ ./client/common.h
+@@ -39,6 +39,7 @@
+ #include <exception>
+ #include <list>
+ #include <string.h>
++#include <cstdarg>
+
+ #ifdef WIN32
+ #ifdef __GNUC__