summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-25 10:35:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-25 10:35:46 +0000
commit9a693067ee9cf55ae097b40fce9101d7e003a81a (patch)
tree9d84a08bb47a1b4119f6ef0734232ff452a56ed4 /testing
parentc56b50911fa29bd821e66ea94e3f11fd9ca0ddc0 (diff)
downloadaports-9a693067ee9cf55ae097b40fce9101d7e003a81a.tar.bz2
aports-9a693067ee9cf55ae097b40fce9101d7e003a81a.tar.xz
main/argp-standalone: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/argp-standalone/001-throw-in-funcdef.patch79
-rw-r--r--testing/argp-standalone/APKBUILD39
2 files changed, 0 insertions, 118 deletions
diff --git a/testing/argp-standalone/001-throw-in-funcdef.patch b/testing/argp-standalone/001-throw-in-funcdef.patch
deleted file mode 100644
index 4a90751e1..000000000
--- a/testing/argp-standalone/001-throw-in-funcdef.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-# --- T2-COPYRIGHT-NOTE-BEGIN ---
-# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
-#
-# T2 SDE: package/.../rng-tools/throw-in-funcdef.patch.argp-standalone
-# Copyright (C) 2006 The T2 SDE Project
-#
-# More information can be found in the files COPYING and README.
-#
-# This patch file is dual-licensed. It is available under the license the
-# patched project is licensed under, as long as it is an OpenSource license
-# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
-# of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or (at your option) any later
-# version.
-# --- T2-COPYRIGHT-NOTE-END ---
-
-
-No __THROW in function implementation.
- --jsaw
-
---- argp-standalone-1.4-test2/argp.h.orig 2006-01-06 02:29:59.000000000 +0100
-+++ argp-standalone-1.4-test2/argp.h 2006-01-06 02:41:10.000000000 +0100
-@@ -560,17 +560,17 @@
- # endif
-
- # ifndef ARGP_EI
--# define ARGP_EI extern __inline__
-+# define ARGP_EI extern inline
- # endif
-
- ARGP_EI void
--__argp_usage (__const struct argp_state *__state) __THROW
-+__argp_usage (__const struct argp_state *__state)
- {
- __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
- }
-
- ARGP_EI int
--__option_is_short (__const struct argp_option *__opt) __THROW
-+__option_is_short (__const struct argp_option *__opt)
- {
- if (__opt->flags & OPTION_DOC)
- return 0;
-@@ -582,7 +582,7 @@
- }
-
- ARGP_EI int
--__option_is_end (__const struct argp_option *__opt) __THROW
-+__option_is_end (__const struct argp_option *__opt)
- {
- return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
- }
---- argp-standalone-1.4-test2/argp-parse.c.orig 2006-01-06 02:47:48.000000000 +0100
-+++ argp-standalone-1.4-test2/argp-parse.c 2006-01-06 02:48:16.000000000 +0100
-@@ -1290,13 +1290,13 @@
- /* Defined here, in case a user is not inlining the definitions in
- * argp.h */
- void
--__argp_usage (__const struct argp_state *__state) __THROW
-+__argp_usage (__const struct argp_state *__state)
- {
- __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
- }
-
- int
--__option_is_short (__const struct argp_option *__opt) __THROW
-+__option_is_short (__const struct argp_option *__opt)
- {
- if (__opt->flags & OPTION_DOC)
- return 0;
-@@ -1310,7 +1310,7 @@
- }
-
- int
--__option_is_end (__const struct argp_option *__opt) __THROW
-+__option_is_end (__const struct argp_option *__opt)
- {
- return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
- }
diff --git a/testing/argp-standalone/APKBUILD b/testing/argp-standalone/APKBUILD
deleted file mode 100644
index 227823cd4..000000000
--- a/testing/argp-standalone/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
-pkgname=argp-standalone
-pkgver=1.3
-pkgrel=0
-pkgdesc="Hierarchial argument parsing library broken out from glibc"
-url="http://www.lysator.liu.se/~nisse/misc/"
-arch="all"
-license="GPL"
-depends=""
-depends_dev="libtool automake autoconf"
-makedepends="$depends_dev"
-install=""
-subpackages=""
-source="http://www.lysator.liu.se/~nisse/misc/$pkgname-$pkgver.tar.gz
- 001-throw-in-funcdef.patch"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr
- make || return 1
-}
-package() {
- cd "$_builddir"
- install -D -m644 argp.h "$pkgdir"/usr/include/argp.h
- install -D -m755 libargp.a "$pkgdir"/usr/lib/libargp.a
-}
-
-md5sums="720704bac078d067111b32444e24ba69 argp-standalone-1.3.tar.gz
-05ba8faf86b1f320127119e9bfc76d1a 001-throw-in-funcdef.patch"