summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-28 14:26:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-28 15:28:47 +0000
commitb0ec029d08195d0f76fc40c3a9ff4092cabf380f (patch)
treee11433d7de1581ad09a87290fcc4a4adc0633dc5 /testing
parentecaea43009efcb1c85fb32ab6859b171058b7652 (diff)
downloadaports-b0ec029d08195d0f76fc40c3a9ff4092cabf380f.tar.bz2
aports-b0ec029d08195d0f76fc40c3a9ff4092cabf380f.tar.xz
testing/talloc: remove. we have one in main
Diffstat (limited to 'testing')
-rw-r--r--testing/talloc/APKBUILD63
-rw-r--r--testing/talloc/ld_library_path.patch18
2 files changed, 0 insertions, 81 deletions
diff --git a/testing/talloc/APKBUILD b/testing/talloc/APKBUILD
deleted file mode 100644
index 13f81bd68..000000000
--- a/testing/talloc/APKBUILD
+++ /dev/null
@@ -1,63 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=talloc
-pkgver=2.0.8
-pkgrel=0
-pkgdesc="The talloc library"
-url="http://talloc.samba.org/"
-arch="all"
-license="LGPLv3+"
-depends=""
-depends_dev=""
-makedepends="$depends_dev python-dev"
-install=""
-subpackages="$pkgname-dev py-$pkgname:_py"
-source="http://samba.org/ftp/talloc/talloc-$pkgver.tar.gz
- ld_library_path.patch"
-
-_builddir="$srcdir"/talloc-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --bundled-libraries=NONE \
- --builtin-libraries=replace \
- --disable-rpath \
- --disable-rpath-install \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
-}
-
-_py() {
- pkgdesc="Python binding for libtalloc"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
-}
-
-md5sums="7857200b58a8617ca18fe2c91296cd93 talloc-2.0.8.tar.gz
-93da22983adf60cd6d7b546d34bddc72 ld_library_path.patch"
-sha256sums="1ec11e635e0318dbbb014db38ff96e8dba3ce5f614eeb7d993b4a5b71c016783 talloc-2.0.8.tar.gz
-195482b132793af55a426ca996764a943e0f2dc9b3690e7087360739a47e95a9 ld_library_path.patch"
-sha512sums="8e8e71d05443b7ea5d8ac432c1043840000b7b6ebeff6a2f621274f29a298e6c64ad5fb75b59c6138179c5602d6164695b85b57b5b310809150320b6eecd487f talloc-2.0.8.tar.gz
-866f272caf3ce44afc3fa00fc148a213b74b3133e45434f3cf6f2653f0bec827bc0eace9d71704778bcc118d53cf222f507983ff3be947cf56a63bc6e042d394 ld_library_path.patch"
diff --git a/testing/talloc/ld_library_path.patch b/testing/talloc/ld_library_path.patch
deleted file mode 100644
index 1ae95ec1a..000000000
--- a/testing/talloc/ld_library_path.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-uclibc does not seem to handle a leading ':' in LD_LIBRARY_PATH.
-Eg. LD_LIBRARY_PATH=":/path"
-
---- ./buildtools/wafsamba/samba_utils.py.orig 2013-08-01 13:16:13.425790642 +0000
-+++ ./buildtools/wafsamba/samba_utils.py 2013-08-01 13:17:52.063543307 +0000
-@@ -54,10 +54,9 @@
- def ADD_LD_LIBRARY_PATH(path):
- '''add something to LD_LIBRARY_PATH'''
- if 'LD_LIBRARY_PATH' in os.environ:
-- oldpath = os.environ['LD_LIBRARY_PATH']
-+ newpath = os.environ['LD_LIBRARY_PATH'].split(':')
- else:
-- oldpath = ''
-- newpath = oldpath.split(':')
-+ newpath = []
- if not path in newpath:
- newpath.append(path)
- os.environ['LD_LIBRARY_PATH'] = ':'.join(newpath)