summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-31 10:15:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-31 11:47:35 +0000
commitb36ef94fcd95bbd2b726192cc5d1e35a5e263584 (patch)
tree48bc1011b0ed77ab3015a5bc976b6e22c44fc3b8 /testing
parent8ae206c7e6c7a4f7a79b5d7ab60335cb34e1eb50 (diff)
downloadaports-b36ef94fcd95bbd2b726192cc5d1e35a5e263584.tar.bz2
aports-b36ef94fcd95bbd2b726192cc5d1e35a5e263584.tar.xz
testing/iniparser: new aport
C library for parsing INI-style files http://ndevilla.free.fr/iniparser/
Diffstat (limited to 'testing')
-rw-r--r--testing/iniparser/APKBUILD52
-rw-r--r--testing/iniparser/rpath.patch13
2 files changed, 65 insertions, 0 deletions
diff --git a/testing/iniparser/APKBUILD b/testing/iniparser/APKBUILD
new file mode 100644
index 000000000..b5bab989f
--- /dev/null
+++ b/testing/iniparser/APKBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=iniparser
+pkgver=3.1
+pkgrel=0
+pkgdesc="C library for parsing "INI-style" files"
+url="http://ndevilla.free.fr/iniparser/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://ndevilla.free.fr/iniparser/iniparser-$pkgver.tar.gz
+ rpath.patch"
+
+_builddir="$srcdir"/iniparser
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make CC="${CC:-gcc}" CFLAGS="${CFLAGS}" LDFLAGS="$LDFLAGS" \
+ libiniparser.so || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/lib "$pkgdir"/usr/include || return 1
+ install -m 644 src/dictionary.h "$pkgdir"/usr/include/dictionary.h \
+ || return 1
+ install -m 644 src/iniparser.h "$pkgdir"/usr/include/iniparser.h \
+ || return 1
+ install -m 755 libiniparser.so.0 "$pkgdir"/usr/lib/libiniparser.so.0 \
+ || return 1
+ ln -s libiniparser.so.0 "$pkgdir"/usr/lib/libiniparser.so \
+ || return 1
+}
+
+md5sums="0aa4f995468ed390caf323f50a285bc3 iniparser-3.1.tar.gz
+67f622f6a1e5d4631c5c7db6c1f19fcb rpath.patch"
+sha256sums="aedf23881b834519aea5e861b2400606d211da049cd59d3cfb4568e0d9eff5c5 iniparser-3.1.tar.gz
+8704113db821b23426861a33792003a846fbc5b27d23ad204bedcbeb7635a984 rpath.patch"
+sha512sums="8fd8324c5629fdc3e3eff00afb5f0832402ccc760c5b92db82aa29b340ec891419ca2c4fee3a4d4d67cf9bc51c76b095bc0c458e087c2b8e72ac36867c47ae86 iniparser-3.1.tar.gz
+611f8c4a2499d97b9cf86914df09e15bb619fdaedb44195106afbc6376dcf08528ed28102727215ea2191540f6523f689050fc40b71e0b0dc2fdb5e9040ed663 rpath.patch"
diff --git a/testing/iniparser/rpath.patch b/testing/iniparser/rpath.patch
new file mode 100644
index 000000000..2f6e25c6d
--- /dev/null
+++ b/testing/iniparser/rpath.patch
@@ -0,0 +1,13 @@
+--- ./Makefile.orig 2013-10-31 10:10:47.200997664 +0000
++++ ./Makefile 2013-10-31 10:13:18.609360807 +0000
+@@ -11,8 +11,8 @@
+ ARFLAGS = rcv
+
+ SHLD = ${CC} ${CFLAGS}
+-LDSHFLAGS = -shared -Wl,-Bsymbolic -Wl,-rpath -Wl,/usr/lib -Wl,-rpath,/usr/lib
+-LDFLAGS = -Wl,-rpath -Wl,/usr/lib -Wl,-rpath,/usr/lib
++LDSHFLAGS = -shared -Wl,-Bsymbolic
++LDFLAGS =
+
+ # Set RANLIB to ranlib on systems that require it (Sun OS < 4, Mac OSX)
+ # RANLIB = ranlib