summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-28 18:01:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-30 08:23:15 +0000
commitbcc4a8d35065de9e9dce30c6680848637173d907 (patch)
treee9e6773d763729a2847668e042c6b09699e55738 /testing
parent220fc5787648fabad98cdd83efa90abe33b9061d (diff)
downloadaports-bcc4a8d35065de9e9dce30c6680848637173d907.tar.bz2
aports-bcc4a8d35065de9e9dce30c6680848637173d907.tar.xz
testing/py-webob: new aport
A Python WSGI request and response objects http://webob.org/
Diffstat (limited to 'testing')
-rw-r--r--testing/py-webob/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-webob/APKBUILD b/testing/py-webob/APKBUILD
new file mode 100644
index 000000000..f2d15b626
--- /dev/null
+++ b/testing/py-webob/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-webob
+_pkgname=WebOb
+pkgver=1.2.3
+pkgrel=0
+pkgdesc="A Python WSGI request and response objects"
+url="http://webob.org/"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools py-tempita py-dtopt"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="11825b7074ba7043e157805e4e6e0f55 WebOb-1.2.3.tar.gz"
+sha256sums="325c249f3ac35e72b75ba13b2c60317def0c986a24a413ebf700509ea4c73a13 WebOb-1.2.3.tar.gz"
+sha512sums="831e6bb1d2c6998b6929520098ed4aed3117d038457d9bba28ceba090bf32fcf6a935f88470bee1e0782f6c43395c4fa646d354c946596cc307edb7808e90559 WebOb-1.2.3.tar.gz"