summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 12:06:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-30 08:23:16 +0000
commitca88c5dfeca7e9b349ff855459082e1b4fa40eb8 (patch)
tree84322d568d456eb08ea4521a1b0ee04259654689 /testing
parent50d02e764811c256adeb4f66adf9655ef8b19f42 (diff)
downloadaports-ca88c5dfeca7e9b349ff855459082e1b4fa40eb8.tar.bz2
aports-ca88c5dfeca7e9b349ff855459082e1b4fa40eb8.tar.xz
testing/py-pyramid-addons: new aport
A pyramid plugin that provides extra functionality https://github.com/bboe/pyramid_addons
Diffstat (limited to 'testing')
-rw-r--r--testing/py-pyramid-addons/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-pyramid-addons/APKBUILD b/testing/py-pyramid-addons/APKBUILD
new file mode 100644
index 000000000..23ab293e2
--- /dev/null
+++ b/testing/py-pyramid-addons/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pyramid-addons
+_pkgname=pyramid_addons
+pkgver=0.16
+pkgrel=0
+pkgdesc="A pyramid plugin that provides extra functionality"
+url="https://github.com/bboe/pyramid_addons"
+arch="noarch"
+license="BSD"
+depends="python py-pyramid"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="c13a4174d5bca84c2846ed4e70279695 pyramid_addons-0.16.tar.gz"
+sha256sums="b0e8737aa6eda35debcabd909d5ff84ea0ee43314f284f04be924abb3a123c9d pyramid_addons-0.16.tar.gz"
+sha512sums="c7de8203093e4859fa7a7f9a8188c92aade7860031e7c453fe5d3b1b2d9435c0cefba984996b9875348fdc340084feb4ec4e599f0b58cc73e6c39929a3be872a pyramid_addons-0.16.tar.gz"