summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-03-18 16:48:22 +0000
committerMichael Mason <ms13sp@gmail.com>2009-03-18 16:48:22 +0000
commitf59fc0dd7bbc2469ada752fe6edc96dea3da8c04 (patch)
tree50142a07ff00df0e58e3d913cda7b982957d1c0d /testing
parent4faf6321585e20a6140b0fdc386b5ac418457214 (diff)
downloadaports-f59fc0dd7bbc2469ada752fe6edc96dea3da8c04.tar.bz2
aports-f59fc0dd7bbc2469ada752fe6edc96dea3da8c04.tar.xz
Tested arpwatch build. Moving to extra
Diffstat (limited to 'testing')
-rw-r--r--testing/arpwatch/APKBUILD36
-rw-r--r--testing/arpwatch/arpwatch.confd12
-rw-r--r--testing/arpwatch/arpwatch.initd37
3 files changed, 0 insertions, 85 deletions
diff --git a/testing/arpwatch/APKBUILD b/testing/arpwatch/APKBUILD
deleted file mode 100644
index ed18e5966..000000000
--- a/testing/arpwatch/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer:
-pkgname=arpwatch
-pkgver=2.1a15
-pkgrel=0
-pkgdesc="Ethernet monitoring program"
-url="http://www-nrg.ee.lbl.gov/"
-license="GPL"
-depends="uclibc libpcap"
-makedepends="libpcap-dev"
-install=
-subpackages=""
-source="ftp://ftp.ee.lbl.gov/$pkgname.tar.gz
- arpwatch.confd
- arpwatch.initd"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make -j1 || return 1
- #install command wouldn't create directory ?
- mkdir -p "$pkgdir"/usr/sbin/
- make -j1 DESTDIR="$pkgdir" install
-
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-
-}
-
-md5sums="cebfeb99c4a7c2a6cee2564770415fe7 arpwatch.tar.gz
-dc8300ce5f02d6be95899a2982397064 arpwatch.confd
-404226ad0d10ce9b46b76f058e572426 arpwatch.initd"
diff --git a/testing/arpwatch/arpwatch.confd b/testing/arpwatch/arpwatch.confd
deleted file mode 100644
index f44221aa3..000000000
--- a/testing/arpwatch/arpwatch.confd
+++ /dev/null
@@ -1,12 +0,0 @@
-# Config file for /etc/init.d/arpwatch
-# see arpwatch.8 for more information
-
-#IFACES="eth0 eth1"
-IFACES="eth0"
-
-# Additional options to pass to arpwatch.
-OPTIONS="-N -p"
-
-# Comment this line if you wish arpwatch to run as root user (not recommended)
-ARPUSER="arpwatch"
-
diff --git a/testing/arpwatch/arpwatch.initd b/testing/arpwatch/arpwatch.initd
deleted file mode 100644
index e039e1db8..000000000
--- a/testing/arpwatch/arpwatch.initd
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/net-analyzer/arpwatch/files/arpwatch.initd,v 1.1 2007/06/02 22:37:16 jokey Exp $
-
-depend() {
- need net
-}
-
-start() {
- for IFACE in ${IFACES}
- do
- ebegin "Starting arpwatch on ${IFACE}"
- DATAFILE=/var/lib/arpwatch/${IFACE}.dat
- [ ! -f ${DATAFILE} ] && touch ${DATAFILE}
-
- if [ -z ${ARPUSER} ]; then
- start-stop-daemon --start --quiet --pidfile=/var/run/arpwatch.${IFACE}.pid --exec \
- /usr/sbin/arpwatch -- -i ${IFACE} -f ${DATAFILE} -P /var/run/arpwatch.${IFACE}.pid ${OPTIONS}
- else
- chown ${ARPUSER} ${DATAFILE}
- start-stop-daemon --start --quiet --pidfile=/var/run/arpwatch.${IFACE}.pid --exec \
- /usr/sbin/arpwatch -- -i $IFACE -u ${ARPUSER} -f ${DATAFILE} -P /var/run/arpwatch.${IFACE}.pid ${OPTIONS}
- fi
- eend $?
- done
-}
-
-stop() {
- for IFACE in ${IFACES}
- do
- ebegin "Stopping arpwatch on ${IFACE}"
- start-stop-daemon --stop --quiet --pidfile=/var/run/arpwatch.${IFACE}.pid --exec \
- /usr/sbin/arpwatch
- eend $?
- done
-}