summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-04-01 09:52:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-01 14:23:48 +0000
commit98448e635adf9a37b6636b5a0e0e912b87e81046 (patch)
tree38782f69952c961c599ec4717fc903cd8902c65d /testing
parentfa2eddfbf77f73ef29d5a1c1f5db48843e5f6455 (diff)
downloadaports-98448e635adf9a37b6636b5a0e0e912b87e81046.tar.bz2
aports-98448e635adf9a37b6636b5a0e0e912b87e81046.tar.xz
testing/perl-sys-hostname-long: new aport
testing/perl-sys-hostname-long: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-sys-hostname-long/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/perl-sys-hostname-long/APKBUILD b/testing/perl-sys-hostname-long/APKBUILD
new file mode 100644
index 000000000..ebff46af7
--- /dev/null
+++ b/testing/perl-sys-hostname-long/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Jeff Bilyk <jbilyk@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-sys-hostname-long
+_realname=Sys-Hostname-Long
+pkgver=1.4
+pkgrel=0
+pkgdesc="Perl Module to get full hostname"
+url="http://search.cpan.org/~scott/"
+arch="x86 x86_64"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages=""
+source="http://search.cpan.org/CPAN/authors/id/S/SC/SCOTT/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd $_builddir
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd $_builddir
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+
+}
+
+md5sums="a5b3c23754cbcff10e283d16c42ec3d3 Sys-Hostname-Long-1.4.tar.gz"