summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-06 12:06:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-06 12:06:07 +0000
commit41c5ec7ad6cdf9ede20899b20d26009eabb93877 (patch)
tree3d52e5aee67f2e57fbbea481922e3e1f04a8b383 /testing
parentb4292505f7c22dc69f90e24e72264e606571b186 (diff)
downloadaports-41c5ec7ad6cdf9ede20899b20d26009eabb93877.tar.bz2
aports-41c5ec7ad6cdf9ede20899b20d26009eabb93877.tar.xz
testing/xdg-utils: properly detect xfce
Diffstat (limited to 'testing')
-rw-r--r--testing/xdg-utils/APKBUILD15
-rw-r--r--testing/xdg-utils/xfce.patch13
2 files changed, 24 insertions, 4 deletions
diff --git a/testing/xdg-utils/APKBUILD b/testing/xdg-utils/APKBUILD
index 70b268c23..40478cb46 100644
--- a/testing/xdg-utils/APKBUILD
+++ b/testing/xdg-utils/APKBUILD
@@ -2,21 +2,27 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xdg-utils
pkgver=1.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Basic desktop integration functions"
url="http://portland.freedesktop.org/wiki/"
-arch="all"
+arch="noarch"
license="MIT"
depends=
makedepends=
install=
subpackages="$pkgname-doc"
-source="http://portland.freedesktop.org/download/xdg-utils-$pkgver.tgz"
+source="http://portland.freedesktop.org/download/xdg-utils-$pkgver.tgz
+ xfce.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg "$i"; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -33,4 +39,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="348a5b91dc66426505022c74a64b2940 xdg-utils-1.0.2.tgz"
+md5sums="348a5b91dc66426505022c74a64b2940 xdg-utils-1.0.2.tgz
+328567c08a452bdbbedd2f1cca9ac116 xfce.patch"
diff --git a/testing/xdg-utils/xfce.patch b/testing/xdg-utils/xfce.patch
new file mode 100644
index 000000000..3899a99a5
--- /dev/null
+++ b/testing/xdg-utils/xfce.patch
@@ -0,0 +1,13 @@
+diff --git a/scripts/xdg-open b/scripts/xdg-open
+index 4cc18a8..e7ed9c3 100755
+--- a/scripts/xdg-open
++++ b/scripts/xdg-open
+@@ -303,7 +303,7 @@ detectDE()
+ {
+ if [ x"$KDE_FULL_SESSION" = x"true" ]; then DE=kde;
+ elif [ x"$GNOME_DESKTOP_SESSION_ID" != x"" ]; then DE=gnome;
+- elif xprop -root _DT_SAVE_MODE | grep ' = \"xfce4\"$' >/dev/null 2>&1; then DE=xfce;
++ elif [ -x /usr/bin/exo-open ]; then DE=xfce;
+ fi
+ }
+