summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-19 13:55:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-19 13:55:44 +0000
commit4e671185f1cf09fca541a09b76dfba66a9997457 (patch)
treef88f7cf849f9f4545825e753aa4d86d963ede97b /testing
parentb37f6dadfa10bf9128c928bc88287cfc6aa30c88 (diff)
parent294f465d02aac90efd6b0f5a4d82cd4e8ae91b14 (diff)
downloadaports-4e671185f1cf09fca541a09b76dfba66a9997457.tar.bz2
aports-4e671185f1cf09fca541a09b76dfba66a9997457.tar.xz
Merge git://github.com/Barthalion/aports
provides rtorrent
Diffstat (limited to 'testing')
-rw-r--r--testing/libtorrent/APKBUILD31
-rw-r--r--testing/rtorrent/APKBUILD41
2 files changed, 72 insertions, 0 deletions
diff --git a/testing/libtorrent/APKBUILD b/testing/libtorrent/APKBUILD
new file mode 100644
index 000000000..06865bc7e
--- /dev/null
+++ b/testing/libtorrent/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=libtorrent
+pkgver=0.12.9
+pkgrel=1
+pkgdesc='BitTorrent library written in C++'
+url='http://libtorrent.rakshasa.no/'
+arch='all'
+license='GPL'
+makedepends='libsigc++-dev openssl-dev'
+subpackages="$pkgname-dev"
+options='libtool'
+source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-debug \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="b128bbd324f03eb42ef5060080f87548 libtorrent-0.12.9.tar.gz"
diff --git a/testing/rtorrent/APKBUILD b/testing/rtorrent/APKBUILD
new file mode 100644
index 000000000..9987bf112
--- /dev/null
+++ b/testing/rtorrent/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=rtorrent
+pkgver=0.8.9
+pkgrel=1
+pkgdesc='Ncurses BitTorrent client based on libTorrent'
+url='http://libtorrent.rakshasa.no/'
+license='GPL'
+arch='all'
+makedepends='libsigc++-dev libtorrent-dev curl-dev xmlrpc-c-dev'
+subpackages="$pkgname-doc"
+source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export LDFLAGS="${LDFLAGS} -lpthread"
+ ./configure \
+ --prefix=/usr \
+ --enable-debug \
+ --with-xmlrpc-c \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+doc() {
+ mkdir -p "$subpkgdir" || return 1
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D doc/faq.xml "${subpkgdir}"/usr/share/doc/rtorrent/faq.xml || return 1
+ install -D doc/rtorrent.1 "${subpkgdir}"/usr/share/man/man1/rtorrent.1 || return 1
+ install -D doc/rtorrent.rc "${subpkgdir}"/usr/share/doc/rtorrent/rtorrent.rc || return 1
+}
+
+md5sums="629247636cb1210663b52dadbd040a6c rtorrent-0.8.9.tar.gz"