summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-25 20:33:12 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-25 20:33:12 -0600
commit91e0b79a67a9fd07431cf36931a33050a58fe8dd (patch)
treeaf823122e71a4d0cdb89113aa4723060d6e2f048 /testing
parent52b68ff009a1de30104c9d2e89fd37af038e2ff6 (diff)
downloadaports-91e0b79a67a9fd07431cf36931a33050a58fe8dd.tar.bz2
aports-91e0b79a67a9fd07431cf36931a33050a58fe8dd.tar.xz
testing/xulrunner: build against libfts, drop FTS stub patch
Diffstat (limited to 'testing')
-rw-r--r--testing/xulrunner/APKBUILD9
-rw-r--r--testing/xulrunner/ipc-chromium-uclibc.patch133
-rw-r--r--testing/xulrunner/mozconfig1
3 files changed, 5 insertions, 138 deletions
diff --git a/testing/xulrunner/APKBUILD b/testing/xulrunner/APKBUILD
index 4370f5fb9..8c47f2e8e 100644
--- a/testing/xulrunner/APKBUILD
+++ b/testing/xulrunner/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xulrunner
pkgver=1.9.2.13
-pkgrel=8
+pkgrel=9
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
arch="all"
@@ -25,7 +25,8 @@ depends_dev="nspr-dev
hunspell-dev
startup-notification-dev
sqlite-dev
- libidl-dev"
+ libidl-dev
+ fts-dev"
makedepends="$depends_dev
autoconf2.13
@@ -51,7 +52,6 @@ source="http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/${pkgver}
mozjs-c99math.patch
- ipc-chromium-uclibc.patch
ipc-chromium-execinfo.patch
fix-mozilla-portability-cluelessness-libpr0n-edition.patch"
@@ -103,13 +103,12 @@ dev() {
}
md5sums="211464d0b19b21ce0db63f7bd6549466 xulrunner-1.9.2.13.source.tar.bz2
-a2d246e51e0df2cb5ff050b7b14b2c52 mozconfig
+d0908177f4c3879817f5dc7287cbb2b2 mozconfig
faecc31fd371db93311109117f6bcc40 enable-x86_64-tracemonkey.patch
86d33a17286131d9ef4cdfb35ee56f1f fix-xulrunner-launcher.patch
d839d1c4ef736e6d89ccf91b23b965a4 mozilla-pkgconfig.patch
39e3c85c80f7897ac463e7fe7ad9a343 xulrunner-png14.patch
371303c5bdc4fa0d955d14521b93b69d xulrunner-version.patch
03b73ac11442a26a978c53a6c114ef2b mozjs-c99math.patch
-cc43eda512814f11079ce64001cd3652 ipc-chromium-uclibc.patch
ac1c3725167eb26c89d62b1818810ee4 ipc-chromium-execinfo.patch
7123ec519e3a4d2c8d07369065a61dc7 fix-mozilla-portability-cluelessness-libpr0n-edition.patch"
diff --git a/testing/xulrunner/ipc-chromium-uclibc.patch b/testing/xulrunner/ipc-chromium-uclibc.patch
deleted file mode 100644
index 52fbeff5e..000000000
--- a/testing/xulrunner/ipc-chromium-uclibc.patch
+++ /dev/null
@@ -1,133 +0,0 @@
---- mozilla-1.9.2/ipc/chromium/src/base/file_util.h
-+++ mozilla-1.9.2.orig/ipc/chromium/src/base/file_util.h
-@@ -13,7 +13,6 @@
- #if defined(OS_WIN)
- #include <windows.h>
- #elif defined(OS_POSIX)
--#include <fts.h>
- #include <sys/stat.h>
- #endif
-
-@@ -463,9 +462,6 @@
- #if defined(OS_WIN)
- WIN32_FIND_DATA find_data_;
- HANDLE find_handle_;
--#elif defined(OS_POSIX)
-- FTS* fts_;
-- FTSENT* fts_ent_;
- #endif
-
- DISALLOW_EVIL_CONSTRUCTORS(FileEnumerator);
---- mozilla-1.9.2/ipc/chromium/src/base/file_util_posix.cc
-+++ mozilla-1.9.2.orig/ipc/chromium/src/base/file_util_posix.cc
-@@ -8,7 +8,6 @@
- #include <errno.h>
- #include <fcntl.h>
- #include <fnmatch.h>
--#include <fts.h>
- #include <libgen.h>
- #include <stdio.h>
- #include <string.h>
-@@ -103,6 +102,7 @@
- // that functionality. If not, remove from file_util_win.cc, otherwise add it
- // here.
- bool Delete(const FilePath& path, bool recursive) {
-+#if 0
- const char* path_str = path.value().c_str();
- struct stat64 file_info;
- int test = stat64(path_str, &file_info);
-@@ -155,6 +155,9 @@
- fts_close(fts);
- }
- return success;
-+#else
-+ return false;
-+#endif
- }
-
- bool Move(const FilePath& from_path, const FilePath& to_path) {
-@@ -171,6 +174,7 @@
- bool CopyDirectory(const FilePath& from_path,
- const FilePath& to_path,
- bool recursive) {
-+#if 0
- // Some old callers of CopyDirectory want it to support wildcards.
- // After some discussion, we decided to fix those callers.
- // Break loudly here if anyone tries to do this.
-@@ -270,6 +274,7 @@
- LOG(ERROR) << "CopyDirectory(): " << strerror(error);
- return false;
- }
-+#endif
- return true;
- }
-
-@@ -506,8 +511,11 @@
- FileEnumerator::FILE_TYPE file_type)
- : recursive_(recursive),
- file_type_(file_type),
-- is_in_find_op_(false),
-- fts_(NULL) {
-+ is_in_find_op_(false)
-+#if 0
-+ ,fts_(NULL)
-+#endif
-+{
- pending_paths_.push(root_path);
- }
-
-@@ -518,8 +526,11 @@
- : recursive_(recursive),
- file_type_(file_type),
- pattern_(root_path.value()),
-- is_in_find_op_(false),
-- fts_(NULL) {
-+ is_in_find_op_(false)
-+#if 0
-+ ,fts_(NULL)
-+#endif
-+{
- // The Windows version of this code only matches against items in the top-most
- // directory, and we're comparing fnmatch against full paths, so this is the
- // easiest way to get the right pattern.
-@@ -528,11 +539,14 @@
- }
-
- FileEnumerator::~FileEnumerator() {
-+#if 0
- if (fts_)
- fts_close(fts_);
-+#endif
- }
-
- void FileEnumerator::GetFindInfo(FindInfo* info) {
-+#if 0
- DCHECK(info);
-
- if (!is_in_find_op_)
-@@ -540,6 +554,7 @@
-
- memcpy(&(info->stat), fts_ent_->fts_statp, sizeof(info->stat));
- info->filename.assign(fts_ent_->fts_name);
-+#endif
- }
-
- // As it stands, this method calls itself recursively when the next item of
-@@ -547,6 +562,7 @@
- // large directories with many files this can be quite deep.
- // TODO(erikkay) - get rid of this recursive pattern
- FilePath FileEnumerator::Next() {
-+#if 0
- if (!is_in_find_op_) {
- if (pending_paths_.empty())
- return FilePath();
-@@ -600,6 +616,9 @@
- }
- // TODO(erikkay) - verify that the other fts_info types aren't interesting
- return Next();
-+#else
-+ return FilePath();
-+#endif
- }
-
- ///////////////////////////////////////////////
diff --git a/testing/xulrunner/mozconfig b/testing/xulrunner/mozconfig
index 79fcec01d..90b0bea4c 100644
--- a/testing/xulrunner/mozconfig
+++ b/testing/xulrunner/mozconfig
@@ -31,6 +31,7 @@ ac_add_options --enable-safe-browsing
ac_add_options --enable-startup-notification
ac_add_options --enable-extensions=default
+export LIBS="-lfts"
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1