summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-29 07:21:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-29 07:31:44 +0000
commit21e2a18d351237f040d5bdcad0a42b870197f457 (patch)
tree2047eda93c940368f049e60dbba1f06a527d6ca3 /testing
parent5f0443a23cbf65da480fd8d27280894e13979457 (diff)
downloadaports-21e2a18d351237f040d5bdcad0a42b870197f457.tar.bz2
aports-21e2a18d351237f040d5bdcad0a42b870197f457.tar.xz
testing/perl-unicode-string: recreate with apkbuild-cpan
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-unicode-string/APKBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/testing/perl-unicode-string/APKBUILD b/testing/perl-unicode-string/APKBUILD
index 0921bbda0..287eb44b5 100644
--- a/testing/perl-unicode-string/APKBUILD
+++ b/testing/perl-unicode-string/APKBUILD
@@ -1,35 +1,33 @@
+# Automatically generated by apkbuild-cpan, template 1
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-unicode-string
+_pkgreal=Unicode-String
pkgver=2.09
-pkgrel=1
+pkgrel=2
pkgdesc="String of Unicode characters for perl (UCS2/UTF16)"
url="http://search.cpan.org/dist/Unicode-String/"
arch="all"
-license="PerlArtistic"
-depends="perl"
-depends_dev="perl-dev"
-makedepends="$depends_dev"
-install=""
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Unicode-String-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir"/Unicode-String-$pkgver
+_builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- local i
cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
}
package() {