summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-24 07:52:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-24 07:52:25 +0000
commit465cf33483bf57bb455b656050e1c2e9fe761af4 (patch)
treedc2ef906c84c3685f5dfdcd504a2e2223c72d7d4 /testing
parent8cbeac914c709e557efae6e450ce41b3ed587246 (diff)
downloadaports-465cf33483bf57bb455b656050e1c2e9fe761af4.tar.bz2
aports-465cf33483bf57bb455b656050e1c2e9fe761af4.tar.xz
testing/kamailio: fix default config
from nangel. fixes #362
Diffstat (limited to 'testing')
-rw-r--r--testing/kamailio/APKBUILD4
-rw-r--r--testing/kamailio/kamailio.cfg54
2 files changed, 29 insertions, 29 deletions
diff --git a/testing/kamailio/APKBUILD b/testing/kamailio/APKBUILD
index 3ca4e5bad..db7af6dac 100644
--- a/testing/kamailio/APKBUILD
+++ b/testing/kamailio/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=kamailio
pkgver=3.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="Open Source SIP Server"
url="http://www.kamailio.org/"
pkgusers="kamailio"
@@ -148,7 +148,7 @@ unixodbc() {
}
md5sums="dd039e078a77032a423fb15f9685ad31 kamailio-3.0.2_src.tar.gz
-865979ca14a727e99e0de5ca2426603f kamailio.cfg
+a3c959ec568c43a905710e7d25cd8c25 kamailio.cfg
81100c479890a2a8c2628db22fdd1a0c kamailio.initd
c646af2dd31f5c4289a2f802c873d98f kamailio.pre-install
3fbaf633ff1620d0d526fc4047c7bed9 kamailio.post-install
diff --git a/testing/kamailio/kamailio.cfg b/testing/kamailio/kamailio.cfg
index 5a45cfdbb..1558cce9c 100644
--- a/testing/kamailio/kamailio.cfg
+++ b/testing/kamailio/kamailio.cfg
@@ -1,13 +1,14 @@
-# Demonstration Kamailio Configuration for AlpineLinux
-
+# Sample Kamailio Configuration
+# 23 June 2010 - For Alpine Linux
+# Accepts all registrations; routes calls to any registered AOR
#--------------------------------------------------------
# Section 1: Global Definitions
#--------------------------------------------------------
-debug = 3
+debug = 2
fork = yes
log_stderror = no
-listen = 0.0.0.0
+# listen = 0.0.0.0
port = 5060
children = 4
@@ -15,20 +16,24 @@ dns = no
rev_dns = no
mpath = "/usr/lib/kamailio/modules_k/:/usr/lib/kamailio/modules/"
+
#--------------------------------------------------------
# Section 2: Modules
#--------------------------------------------------------
-loadmodule "sl.so"
loadmodule "tm.so"
+loadmodule "sl.so"
+loadmodule "tmx.so"
loadmodule "rr.so"
loadmodule "maxfwd.so"
loadmodule "usrloc.so"
loadmodule "registrar.so"
loadmodule "mi_fifo.so"
+loadmodule "pv.so"
+loadmodule "xlog.so"
#--------------------------------------------------------
-# Section 1: Module Configuration
+# Section 3: Module Configuration
#--------------------------------------------------------
modparam ( "usrloc", "db_mode", 0 )
@@ -36,26 +41,30 @@ modparam ( "rr", "enable_full_lr", 1 )
modparam ( "mi_fifo", "fifo_name", "/tmp/kamailio_fifo")
#--------------------------------------------------------
-# Section 1: Main Route Block
+# Section 4: Main Route Block
#--------------------------------------------------------
route
- {
+ {
+ # Uncomment next line if you want to see
+ # each incoming message
+ xlog( "L_INFO", "$rm: $fu -> $ru" );
+
if (!mf_process_maxfwd_header("10"))
{
sl_send_reply("483", "Too Many Hops");
return;
}
-
- if (msg:len > max_len)
+
+ if (msg:len > 4096)
{
- sl_send_reply("513", "Message Overflow");
+ sl_send_reply("513", "Message too big" );
return;
}
if (method == "REGISTER" )
{
- route(2);
+ route(REGISTER);
return;
}
@@ -66,42 +75,33 @@ route
return;
}
- route(1);
+ route(RELAY);
}
#--------------------------------------------------------
-# Section 1: Secondary Route Blocks
+# Section 5: Secondary Route Blocks
#--------------------------------------------------------
# - Default message handler
-route[1] {
+route[RELAY] {
if (!t_relay()) {
sl_reply_error();
}
}
#- Registration Request
-route[2] {
+route[REGISTER] {
if (!save("location")) {
sl_reply_error();
}
}
#--------------------------------------------------------
-# Section 1: Reply Route Block
+# Section 6: Reply Route Block
#--------------------------------------------------------
#--------------------------------------------------------
-# Section 1: Failure Route Block
+# Section 7: Failure Route Block
#--------------------------------------------------------
-
-
-
-
-
-
-
-
-