summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-11-07 21:41:01 +0100
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-11-07 21:51:32 +0100
commit686829c07b3b12899ae8e388869e54b429dc658a (patch)
tree7858c7b34af6d779fdf2b9315c52a31223df1ec8 /testing
parent69c10cdb359030db0fa2d1d9f26980febf342690 (diff)
downloadaports-686829c07b3b12899ae8e388869e54b429dc658a.tar.bz2
aports-686829c07b3b12899ae8e388869e54b429dc658a.tar.xz
testing/libstrophe: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libstrophe/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/libstrophe/APKBUILD b/testing/libstrophe/APKBUILD
new file mode 100644
index 000000000..1d7b6481b
--- /dev/null
+++ b/testing/libstrophe/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=libstrophe
+pkgver=0.8.6
+pkgrel=0
+epoch=1
+pkgdesc='Simple, lightweight C library for writing XMPP clients'
+arch=all
+url='http://strophe.im/libstrophe/'
+license='MIT'
+depends=
+makedepends='openssl-dev expat-dev check-dev libstrophe automake libtool'
+subpackages="$pkgname-dev"
+source="https://github.com/strophe/libstrophe/archive/$pkgver.tar.gz"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./bootstrap.sh || return 1
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make check || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 MIT-LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE-MIT
+ find "$pkgdir" -name \*.la -delete
+}
+
+md5sums="5ab28dc86c47177819ca49ed9c0041e0 0.8.6.tar.gz"
+sha256sums="a2158134381e544a7697e9379f45abe18da817cd05eb3272eabec2151599d702 0.8.6.tar.gz"
+sha512sums="5c93a199d223d0995c99688dcd9af1586e17ce825d0df3cdac33498c87af62a41a60b4a727910754f064541c64f9b79d5db899a265a1cc3d9c4380e42b525e5a 0.8.6.tar.gz"