summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-29 10:00:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-29 10:02:33 +0000
commitbc60297a465f4cb48d061258d907f83f6f851bbd (patch)
treecfdf36d473b1cb36ecb50d2034c368eef400eee4 /testing
parent2044e42fd103c37bfeb0c7cfebf9c35853bce91d (diff)
downloadaports-bc60297a465f4cb48d061258d907f83f6f851bbd.tar.bz2
aports-bc60297a465f4cb48d061258d907f83f6f851bbd.tar.xz
testing/redshift: new aport
Adjusts the color temperature of your screen according to your surroundings. http://jonls.dk/redshift/
Diffstat (limited to 'testing')
-rw-r--r--testing/redshift/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/redshift/APKBUILD b/testing/redshift/APKBUILD
new file mode 100644
index 000000000..4718fb88b
--- /dev/null
+++ b/testing/redshift/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: 7heo <7heo@mail.com>
+pkgname=redshift
+pkgver=1.9
+pkgrel=0
+pkgdesc="Adjusts the color temperature of your screen according to your surroundings."
+url="http://jonls.dk/redshift/"
+arch="all"
+license="GLPv3"
+depends=""
+depends_dev="libxxf86vm-dev libdrm-dev"
+makedepends="$depends_dev"
+install=
+replaces=""
+subpackages="$pkgname-doc"
+source="https://github.com/jonls/redshift/releases/download/v$pkgver/redshift-$pkgver.tar.xz
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case "$i" in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-randr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="9640218cd9ba88f6d10b347b2277c415 redshift-1.9.tar.xz"
+sha256sums="dbfe96e29b131e3e684528055b89c742be63b15aff38dd2f237b0ad8b9daba76 redshift-1.9.tar.xz"
+sha512sums="16476e68c82ca583e4aa8e18da1e34b944a60f29fa516acfcb220d6c7d94d313a71ef5db049758753ab77e5da603876ed7635c29e64521c611b0179553371ad8 redshift-1.9.tar.xz"