summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-17 16:58:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-17 16:58:47 +0000
commit05b96ec9d84aee92aab7567191daee2e4925a338 (patch)
tree0eb1ae3494390c9a2fbed1befe9e2ca6ea07261b /testing
parent4018f1d723c55e25f696cc3bda75cfcf9795d224 (diff)
downloadaports-05b96ec9d84aee92aab7567191daee2e4925a338.tar.bz2
aports-05b96ec9d84aee92aab7567191daee2e4925a338.tar.xz
testing/wkhtmltopdf: new aport
Simple shell utility to convert html to pdf http://wkhtmltopdf.org/
Diffstat (limited to 'testing')
-rw-r--r--testing/wkhtmltopdf/APKBUILD44
-rw-r--r--testing/wkhtmltopdf/qprint.patch26
2 files changed, 70 insertions, 0 deletions
diff --git a/testing/wkhtmltopdf/APKBUILD b/testing/wkhtmltopdf/APKBUILD
new file mode 100644
index 000000000..431baa52c
--- /dev/null
+++ b/testing/wkhtmltopdf/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wkhtmltopdf
+pkgver=0.12.1
+pkgrel=0
+pkgdesc="Simple shell utility to convert html to pdf"
+url="http://wkhtmltopdf.org/"
+arch="all"
+license="GPLv3+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev qt5-qtbase-dev qt5-qtwebkit-dev qt5-qtsvg-dev
+ qt5-qtxmlpatterns-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/project/wkhtmltopdf/$pkgver/wkhtmltox-$pkgver.tar.bz2
+ qprint.patch"
+
+_builddir="$srcdir"/wkhtmltox-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ qmake -makefile && make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install INSTALL_ROOT="$pkgdir"/usr || return 1
+}
+
+md5sums="6960f2e45469de41314f1a688b1fdaf0 wkhtmltox-0.12.1.tar.bz2
+b39477573f9fb162f4dfcf4f7db5b07b qprint.patch"
+sha256sums="383041db30d6e08b9a6f126193a9e120e2791ff99005c39b1d0adacd53e2faca wkhtmltox-0.12.1.tar.bz2
+dfe8b8e212c7888b1a7c2d9724c2a6839592b2909953d9c5c155da25bef2fc0f qprint.patch"
+sha512sums="b9fd1a3bba4daeb5cd30ad4e31cafa206a935a0bd9cf3666beebe5685acbe4b6c7a34ca7282b4d49ee607ca7153afabb4d5e3005572e64688e90bef750fe8e71 wkhtmltox-0.12.1.tar.bz2
+0358742f9e7b8d5030e7ed8dc6bcfcb73a570ae4824d48e5e961b707e48617ce6c0417072008abb8d68e56b9fd6f5a271417df5d904bde00f41a36321148be3f qprint.patch"
diff --git a/testing/wkhtmltopdf/qprint.patch b/testing/wkhtmltopdf/qprint.patch
new file mode 100644
index 000000000..cb3b5ffd7
--- /dev/null
+++ b/testing/wkhtmltopdf/qprint.patch
@@ -0,0 +1,26 @@
+From b42a07d9825aa4241e2ea77edda8ac049e67bab4 Mon Sep 17 00:00:00 2001
+From: Ashish Kulkarni <kulkarni.ashish@gmail.com>
+Date: Mon, 20 Oct 2014 11:38:23 +0530
+Subject: [PATCH] fix build failure with unpatched Qt >= 5.3
+
+This was originally reported as https://bugs.debian.org/763216
+---
+ common.pri | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/common.pri b/common.pri
+index d11e707..ef78ecb 100644
+--- a/common.pri
++++ b/common.pri
+@@ -43,7 +43,10 @@ win32: CONFIG += console
+ win32-g++*: QMAKE_LFLAGS += -static -static-libgcc -static-libstdc++
+
+ QT += webkit network xmlpatterns svg
+-greaterThan(QT_MAJOR_VERSION, 4): QT += webkitwidgets
++greaterThan(QT_MAJOR_VERSION, 4) {
++ QT += webkitwidgets
++ greaterThan(QT_MINOR_VERSION, 2): QT += printsupport
++}
+
+ # version related information
+ VERSION_TEXT=$$(WKHTMLTOX_VERSION)