summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-09 14:24:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-09 14:24:19 +0000
commit2071623ebaa60880b38e9abf7fc1ffa431b7087a (patch)
treef28167c599ad5b1c673dce3c25a87b2c7dea51a2 /testing
parent44235a5fb40f3d9a036f9116ff2d85dca2dddfc5 (diff)
downloadaports-2071623ebaa60880b38e9abf7fc1ffa431b7087a.tar.bz2
aports-2071623ebaa60880b38e9abf7fc1ffa431b7087a.tar.xz
testing/lua5.2-socket: new aport
Luasocket is the most comprehensive networking support library for the Lua language. http://luaforge.net/projects/luasocket/
Diffstat (limited to 'testing')
-rw-r--r--testing/lua5.2-socket/APKBUILD53
-rw-r--r--testing/lua5.2-socket/include-luasocket.patch10
-rw-r--r--testing/lua5.2-socket/lua-cflags.patch20
-rw-r--r--testing/lua5.2-socket/unix.patch25
4 files changed, 108 insertions, 0 deletions
diff --git a/testing/lua5.2-socket/APKBUILD b/testing/lua5.2-socket/APKBUILD
new file mode 100644
index 000000000..52468d0d4
--- /dev/null
+++ b/testing/lua5.2-socket/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+_luaver=5.2
+pkgname=lua$_luaver-socket
+_name=luasocket
+pkgver=3.0_rc1
+pkgrel=0
+_ver=${pkgver/_/-}
+pkgdesc="Luasocket is the most comprehensive networking support library for the Lua language."
+url="http://luaforge.net/projects/luasocket/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="lua5.2-dev"
+install=
+source="luasocket-$_ver.tar.gz::https://github.com/diegonehab/luasocket/archive/v$_ver.tar.gz
+ lua-cflags.patch
+ include-luasocket.patch"
+
+_builddir="$srcdir/$_name-$_ver"
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ # set lua version
+ sed -i -e "/^LUAV?=/s/=.*/=$_luaver/" src/makefile
+}
+
+build() {
+ cd "$_builddir"
+ make -C src all-unix || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make prefix=/usr DESTDIR="$pkgdir" install-unix
+
+}
+
+md5sums="08bd2f265b244eb4bf5c2c36bf89b759 luasocket-3.0-rc1.tar.gz
+f869d0f81e347291405fb53dff9a408a lua-cflags.patch
+4bcbbc8d3383db94223155fc7a6d454e include-luasocket.patch"
+sha256sums="8b67d9b5b545e1b694753dab7bd6cdbc24c290f2b21ba1e14c77b32817ea1249 luasocket-3.0-rc1.tar.gz
+bbcead4850fcdf6711c70b48db4db17e06fedcae45c4c53fd814ff6f0d9fe4ce lua-cflags.patch
+42b1a439805efaf33110e01a53798b3e8d044101470808fe9478ca3be0ae5165 include-luasocket.patch"
+sha512sums="f6efce259aaacaa11472911471f8a13b118fe009b8953a82c6aa18b9ec829cd1293180904e56935cb130d36d267e3f27c91db2d78e03f7488f3e100571ed0540 luasocket-3.0-rc1.tar.gz
+58b5d3c239c8be1561060f75bf849bcfa9022626995a5234ec741dc2ae86755d9fed88c12b5644c914c604ea31b017a6679ac33a9a76392242faf139bfd59de1 lua-cflags.patch
+34db925f9e9a1a629d01dc26072f4edec77087f7bf89dda8140326447662efbc53ce5e36087fa9127d708d498c129613f7ed82862dd3176df16796418868548d include-luasocket.patch"
diff --git a/testing/lua5.2-socket/include-luasocket.patch b/testing/lua5.2-socket/include-luasocket.patch
new file mode 100644
index 000000000..e227b0414
--- /dev/null
+++ b/testing/lua5.2-socket/include-luasocket.patch
@@ -0,0 +1,10 @@
+--- ./src/serial.c.orig 2013-07-09 14:16:04.793467198 +0000
++++ ./src/serial.c 2013-07-09 14:16:20.230304446 +0000
+@@ -11,6 +11,7 @@
+ #include "socket.h"
+ #include "options.h"
+ #include "unix.h"
++#include "luasocket.h"
+ #include <sys/un.h>
+
+ /*
diff --git a/testing/lua5.2-socket/lua-cflags.patch b/testing/lua5.2-socket/lua-cflags.patch
new file mode 100644
index 000000000..eace4258a
--- /dev/null
+++ b/testing/lua5.2-socket/lua-cflags.patch
@@ -0,0 +1,20 @@
+--- ./src/makefile.orig 2013-07-09 14:20:08.772827698 +0000
++++ ./src/makefile 2013-07-09 14:22:46.311231590 +0000
+@@ -142,6 +142,8 @@
+ #------
+ # Compiler and linker settings
+ # for Linux
++LUAPC=lua$(LUAV)
++LUA_CFLAGS=$(shell pkg-config --cflags $(LUAPC))
+ SO_linux=so
+ O_linux=o
+ CC_linux=gcc
+@@ -149,7 +151,7 @@
+ -DLUASOCKET_API='__attribute__((visibility("default")))' \
+ -DUNIX_API='__attribute__((visibility("default")))' \
+ -DMIME_API='__attribute__((visibility("default")))'
+-CFLAGS_linux= -I$(LUAINC) $(DEF) -pedantic -Wall -Wshadow -Wextra \
++CFLAGS_linux= $(LUA_CFLAGS) -I$(LUAINC) $(DEF) -pedantic -Wall -Wshadow -Wextra \
+ -Wimplicit -O2 -ggdb3 -fpic -fvisibility=hidden
+ LDFLAGS_linux=-O -shared -fpic -o
+ LD_linux=gcc
diff --git a/testing/lua5.2-socket/unix.patch b/testing/lua5.2-socket/unix.patch
new file mode 100644
index 000000000..3de123846
--- /dev/null
+++ b/testing/lua5.2-socket/unix.patch
@@ -0,0 +1,25 @@
+diff --git a/makefile b/makefile
+index 6d70039..a46617a 100644
+--- a/makefile
++++ b/makefile
+@@ -41,6 +41,7 @@ install: all
+ cd src; $(INSTALL_DATA) $(TO_SOCKET_SHARE) $(INSTALL_SOCKET_SHARE)
+ cd src; mkdir -p $(INSTALL_SOCKET_LIB)
+ cd src; $(INSTALL_EXEC) $(SOCKET_SO) $(INSTALL_SOCKET_LIB)/core.$(EXT)
++ cd src; $(INSTALL_EXEC) $(UNIX_SO) $(INSTALL_SOCKET_LIB)/unix.$(EXT)
+ #cd src; mkdir -p $(INSTALL_MIME_SHARE)
+ #cd src; $(INSTALL_DATA) $(TO_MIME_SHARE) $(INSTALL_MIME_SHARE)
+ cd src; mkdir -p $(INSTALL_MIME_LIB)
+diff --git a/src/makefile b/src/makefile
+index b614f77..9a61fb6 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -47,7 +47,7 @@ UNIX_OBJS:=\
+ usocket.o \
+ unix.o
+
+-all: $(SOCKET_SO) $(MIME_SO)
++all: $(SOCKET_SO) $(MIME_SO) $(UNIX_SO)
+
+ $(SOCKET_SO): $(SOCKET_OBJS)
+ $(LD) $(LDFLAGS) -o $@ $(SOCKET_OBJS)